summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool
diff options
context:
space:
mode:
authorShiqun Lin <Shiqun.Lin@windriver.com>2014-11-03 17:08:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-12 15:36:12 +0000
commitd27c4226f600584f83f66c86b0988a165e8ecb75 (patch)
tree03f93523ed97f0e2735a63c90fb7c97eac3778b8 /meta/recipes-devtools/libtool
parent5960262802c394cb6a54ede30e4994929621ca06 (diff)
downloadopenembedded-core-contrib-d27c4226f600584f83f66c86b0988a165e8ecb75.tar.gz
libtool: remove build host paths from installed libtool
Resulted libtool contains references about paths from the build host Below variables contains hard coded build paths from the host: LTCC= lt_sysroot= sys_lib_search_path_spec= LD= CC= compiler_lib_search_dirs= predep_objects= postdep_objects= compiler_lib_search_path= Signed-off-by: Shiqun Lin <Shiqun.Lin@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/libtool')
-rw-r--r--meta/recipes-devtools/libtool/libtool_2.4.2.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool_2.4.2.bb b/meta/recipes-devtools/libtool/libtool_2.4.2.bb
index d3f94284d4..60643129be 100644
--- a/meta/recipes-devtools/libtool/libtool_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool_2.4.2.bb
@@ -9,6 +9,17 @@ RDEPENDS_${PN} += "bash"
#
SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess"
+do_install_append () {
+ sed -e 's@--sysroot=${STAGING_DIR_HOST}@@g' \
+ -e 's@${STAGING_DIR_HOST}@@g' \
+ -e 's@^\(sys_lib_search_path_spec="\).*@\1${libdir} ${base_libdir}"@' \
+ -e 's@^\(compiler_lib_search_dirs="\).*@\1${libdir} ${base_libdir}"@' \
+ -e 's@^\(compiler_lib_search_path="\).*@\1${libdir} ${base_libdir}"@' \
+ -e 's@^\(predep_objects="\).*@\1"@' \
+ -e 's@^\(postdep_objects="\).*@\1"@' \
+ -i ${D}${bindir}/libtool
+}
+
libtool_sysroot_preprocess () {
rm -rf ${SYSROOT_DESTDIR}${bindir}/*
rm -rf ${SYSROOT_DESTDIR}${datadir}/aclocal/*
href='#n198'>198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232