summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-27 16:19:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-28 08:41:08 +0100
commitbedcdc4cf921b70a8cfb16c6684668d0ac9e1942 (patch)
treef8e97a36014e8bfb6dbbdc034d8ad25aeb16d592 /meta/recipes-devtools/librepo
parentf60d261b682f1526fb7a754c425300954ef85042 (diff)
downloadopenembedded-core-contrib-bedcdc4cf921b70a8cfb16c6684668d0ac9e1942.tar.gz
dnf: move the entire dnf/rpm4 stack to Python 3
[YOCTO #11180] Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/librepo')
-rw-r--r--meta/recipes-devtools/librepo/librepo_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/librepo/librepo_git.bb b/meta/recipes-devtools/librepo/librepo_git.bb
index 3f3c5fbcf5..2f194f1439 100644
--- a/meta/recipes-devtools/librepo/librepo_git.bb
+++ b/meta/recipes-devtools/librepo/librepo_git.bb
@@ -16,9 +16,9 @@ S = "${WORKDIR}/git"
DEPENDS = "curl expat glib-2.0 openssl attr libcheck gpgme"
-inherit cmake distutils-base pkgconfig
+inherit cmake distutils3-base pkgconfig
-EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
BBCLASSEXTEND = "native nativesdk"