summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-06-09 05:24:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-12 15:04:11 +0100
commit266545f5f5758be397a6c2cd4727d5c0895c924d (patch)
tree1f834ed82208e4250d886cc468f3e2e54a9cb54e /meta/recipes-devtools/librepo
parent1a6424ee4c865601ff324e9599a2f48c9e6723ee (diff)
downloadopenembedded-core-contrib-266545f5f5758be397a6c2cd4727d5c0895c924d.tar.gz
librepo: Fix typo: correct LRO_SSLVERIFYHOST with CURLOPT_SSL_VERIFYHOST
The commit 51d32c6cd88ba0139c32793183fd6a236c1ef456 in git://github.com/rpm-software-management/librepo.git ... Author: Tomas Mlcoch <tmlcoch@redhat.com> Date: Mon May 5 14:31:35 2014 +0200 Add LRO_SSLVERIFYPEER and LRO_SSLVERIFYHOST options (RhBug: 1093014) ... It incorrectly setopt CURLOPT_SSL_VERIFYPEER for LRO_SSLVERIFYHOST. Use CURLOPT_SSL_VERIFYHOST to correct. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/librepo')
-rw-r--r--meta/recipes-devtools/librepo/librepo/0005-Fix-typo-correct-LRO_SSLVERIFYHOST-with-CURLOPT_SSL_.patch40
-rw-r--r--meta/recipes-devtools/librepo/librepo_git.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/librepo/librepo/0005-Fix-typo-correct-LRO_SSLVERIFYHOST-with-CURLOPT_SSL_.patch b/meta/recipes-devtools/librepo/librepo/0005-Fix-typo-correct-LRO_SSLVERIFYHOST-with-CURLOPT_SSL_.patch
new file mode 100644
index 0000000000..b0c7d1ca30
--- /dev/null
+++ b/meta/recipes-devtools/librepo/librepo/0005-Fix-typo-correct-LRO_SSLVERIFYHOST-with-CURLOPT_SSL_.patch
@@ -0,0 +1,40 @@
+From a4bbbccce6edc1a2d1bd475506e2975fd7696c88 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Thu, 8 Jun 2017 16:31:30 +0800
+Subject: [PATCH] Fix typo: correct LRO_SSLVERIFYHOST with
+ CURLOPT_SSL_VERIFYHOST
+
+In commit 51d32c6cd88ba0139c32793183fd6a236c1ef456
+---
+Author: Tomas Mlcoch <tmlcoch@redhat.com>
+Date: Mon May 5 14:31:35 2014 +0200
+
+ Add LRO_SSLVERIFYPEER and LRO_SSLVERIFYHOST options (RhBug: 1093014)
+---
+
+It incorrectly setopt CURLOPT_SSL_VERIFYPEER for LRO_SSLVERIFYHOST.
+Use CURLOPT_SSL_VERIFYHOST to correct.
+
+Upstream-Status: Submitted
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ librepo/handle.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/librepo/handle.c b/librepo/handle.c
+index ccea79b..ff39db4 100644
+--- a/librepo/handle.c
++++ b/librepo/handle.c
+@@ -629,7 +629,7 @@ lr_handle_setopt(LrHandle *handle,
+
+ case LRO_SSLVERIFYHOST:
+ handle->sslverifyhost = va_arg(arg, long) ? 2 : 0;
+- c_rc = curl_easy_setopt(c_h, CURLOPT_SSL_VERIFYPEER, handle->sslverifyhost);
++ c_rc = curl_easy_setopt(c_h, CURLOPT_SSL_VERIFYHOST, handle->sslverifyhost);
+ break;
+
+ case LRO_SSLCLIENTCERT:
+--
+2.7.4
+
diff --git a/meta/recipes-devtools/librepo/librepo_git.bb b/meta/recipes-devtools/librepo/librepo_git.bb
index 2f194f1439..3238b14fac 100644
--- a/meta/recipes-devtools/librepo/librepo_git.bb
+++ b/meta/recipes-devtools/librepo/librepo_git.bb
@@ -7,6 +7,7 @@ SRC_URI = "git://github.com/rpm-software-management/librepo.git \
file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
file://0003-tests-fix-a-race-when-deleting-temporary-directories.patch \
file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
+ file://0005-Fix-typo-correct-LRO_SSLVERIFYHOST-with-CURLOPT_SSL_.patch \
"
PV = "1.7.20+git${SRCPV}"