summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo/librepo_1.9.6.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-04-01 01:59:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-12 14:04:51 +0100
commit1612b698d13f8e00204b3ad795f23148d72f2611 (patch)
tree360eb7f7a63f1691ab9385f33fd4e40a04424a02 /meta/recipes-devtools/librepo/librepo_1.9.6.bb
parentf6890f97710c4822e4f52c773ea03c8035be8235 (diff)
downloadopenembedded-core-contrib-1612b698d13f8e00204b3ad795f23148d72f2611.tar.gz
librepo: update to 1.9.6
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/librepo/librepo_1.9.6.bb')
-rw-r--r--meta/recipes-devtools/librepo/librepo_1.9.6.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/librepo/librepo_1.9.6.bb b/meta/recipes-devtools/librepo/librepo_1.9.6.bb
new file mode 100644
index 0000000000..fecedc981f
--- /dev/null
+++ b/meta/recipes-devtools/librepo/librepo_1.9.6.bb
@@ -0,0 +1,21 @@
+SUMMARY = " A library providing C and Python (libcURL like) API for downloading linux repository metadata and packages."
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = "git://github.com/rpm-software-management/librepo.git \
+ file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
+ file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
+ "
+
+SRCREV = "7d8acd45eb09809a5ab729c312744da4b2fe92bb"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
+
+inherit cmake distutils3-base pkgconfig
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DENABLE_TESTS=OFF -DENABLE_DOCS=OFF -DWITH_ZCHUNK=OFF"
+
+BBCLASSEXTEND = "native nativesdk"
+