summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo/librepo_1.11.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-19 14:22:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-30 08:45:03 +0000
commit927bdf266a993180d8c700195f80ea9f61199c93 (patch)
treed61123ebcee84710926afc6d3bb6c6ec0bd06dce /meta/recipes-devtools/librepo/librepo_1.11.1.bb
parentb04aeb0c1e17916e473616e97d541f92304c7144 (diff)
downloadopenembedded-core-contrib-927bdf266a993180d8c700195f80ea9f61199c93.tar.gz
librepo: upgrade 1.11.0 -> 1.11.1
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/librepo/librepo_1.11.1.bb')
-rw-r--r--meta/recipes-devtools/librepo/librepo_1.11.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/librepo/librepo_1.11.1.bb b/meta/recipes-devtools/librepo/librepo_1.11.1.bb
new file mode 100644
index 0000000000..dbf1016456
--- /dev/null
+++ b/meta/recipes-devtools/librepo/librepo_1.11.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A library providing C and Python (libcURL like) API \
+ for downloading linux repository metadata and packages."
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = "git://github.com/rpm-software-management/librepo.git \
+ file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
+ file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
+ "
+
+SRCREV = "5ade10012d40fad27a7aa1085091c2c5fdd099ff"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
+
+inherit cmake distutils3-base pkgconfig
+
+EXTRA_OECMAKE = " \
+ -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
+ -DPYTHON_DESIRED=3 \
+ -DENABLE_TESTS=OFF \
+ -DENABLE_DOCS=OFF \
+ -DWITH_ZCHUNK=OFF \
+"
+
+BBCLASSEXTEND = "native nativesdk"