aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libdnf
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-27 16:19:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-28 08:41:08 +0100
commitbedcdc4cf921b70a8cfb16c6684668d0ac9e1942 (patch)
treef8e97a36014e8bfb6dbbdc034d8ad25aeb16d592 /meta/recipes-devtools/libdnf
parentf60d261b682f1526fb7a754c425300954ef85042 (diff)
downloadopenembedded-core-contrib-bedcdc4cf921b70a8cfb16c6684668d0ac9e1942.tar.gz
dnf: move the entire dnf/rpm4 stack to Python 3
[YOCTO #11180] Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libdnf')
-rw-r--r--meta/recipes-devtools/libdnf/libdnf_git.bb17
1 files changed, 3 insertions, 14 deletions
diff --git a/meta/recipes-devtools/libdnf/libdnf_git.bb b/meta/recipes-devtools/libdnf/libdnf_git.bb
index 6e9cfcc862..ef28611f8a 100644
--- a/meta/recipes-devtools/libdnf/libdnf_git.bb
+++ b/meta/recipes-devtools/libdnf/libdnf_git.bb
@@ -17,20 +17,9 @@ S = "${WORKDIR}/git"
DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc"
-inherit gtk-doc gobject-introspection cmake pkgconfig
-
-# We cannot inherit pythonnative (or descendant classes like distutils etc.)
-# because that would conflict with inheriting python3native
-# (which is done by inheriting gobject-introspection).
-# But libdnf only needs the path to native Python 2.x binary
-# so we simply set it explicitly here.
-#
-# These lines can be dropped when dnf stack is moved to python 3.x
-EXTRANATIVEPATH += "python-native"
-FILES_${PN} += " ${libdir}/python2.7/*"
-DEPENDS += "python-native"
-
-EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF \
+inherit gtk-doc gobject-introspection cmake pkgconfig distutils3-base
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF -DPYTHON_DESIRED=3 \
${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \
"
EXTRA_OECMAKE_append_class-native = " -DWITH_GIR=OFF"