aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-09-06 15:20:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 13:01:50 +0100
commitf23d843747208d50770aaabf0796a77b84919a94 (patch)
tree3748bde3d28e9a496591e2798582d066f7cb9754 /meta/recipes-devtools/kconfig-frontends
parent3cfc70fc27c8db79b1f35ca4e1e746fb83ca360f (diff)
downloadopenembedded-core-contrib-f23d843747208d50770aaabf0796a77b84919a94.tar.gz
kconfig-frontends: Create symlinks for conf and mconf
eglibc calls out mconf and conf directly so lets create symlinks to point to their kconfig- counterparts (From OE-Core rev: 5857772e285ad6e39b7216bc542189e45f6fdbf7) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
index 277de03200..96899b842b 100644
--- a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb
@@ -11,7 +11,7 @@ LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
SECTION = "devel"
DEPENDS += "ncurses flex bison gperf"
-PR = "r0"
+PR = "r1"
PV = "3.5.0"
SPIN = "0"
SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz"
@@ -24,6 +24,12 @@ inherit autotools
do_configure_prepend () {
mkdir -p scripts/.autostuff/m4
}
+
+do_install_append() {
+ ln -s kconfig-conf ${D}${bindir}/conf
+ ln -s kconfig-mconf ${D}${bindir}/mconf
+}
+
EXTRA_OECONF += "--disable-gconf --disable-qconf"
# Some packages have the version preceeding the .so instead properly