aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-11-13 21:32:47 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-18 11:45:04 +0000
commit3fb19c1044b46ee7b0d898af4fc6f46bbd957b2f (patch)
treebf60b8a2657c169fda8eff931e316df431bd7ebd /meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
parent1f2f35ba7607b503af2cdf51a459c6de786f554d (diff)
downloadopenembedded-core-contrib-3fb19c1044b46ee7b0d898af4fc6f46bbd957b2f.tar.gz
kconfig-frontends: Update to 3.6
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
new file mode 100644
index 0000000000..d1fdc0e297
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
@@ -0,0 +1,41 @@
+# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "The kconfig-frontends project aims at centralising \
+the effort of keeping an up-to-date, out-of-tree, packaging of the \
+kconfig infrastructure, ready for use by third-party projects. \
+The kconfig-frontends package provides the kconfig parser, as well as all \
+the frontends"
+HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
+SECTION = "devel"
+DEPENDS += "ncurses flex bison gperf"
+PR = "r0"
+PV = "3.6.0"
+SPIN = "0"
+SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz"
+
+SRC_URI[md5sum] = "91ca87abb3c99c3fd40a7babb05ec507"
+SRC_URI[sha256sum] = "3084989a9b146688f318b5524dfb7ab3ba47c9cef355d1aebaa520befdb48da0"
+
+S = "${WORKDIR}/${BPN}-${PV}-${SPIN}"
+
+inherit autotools
+do_configure_prepend () {
+ mkdir -p scripts/.autostuff/m4
+}
+
+do_install_append() {
+ ln -s kconfig-conf ${D}${bindir}/conf
+ ln -s kconfig-mconf ${D}${bindir}/mconf
+}
+
+EXTRA_OECONF += "--disable-gconf --disable-qconf"
+
+# Some packages have the version preceeding the .so instead properly
+# versioned .so.<version>, so we need to reorder and repackage.
+SOLIBS = "-${PV}.so"
+FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
+
+BBCLASSEXTEND = "native"