summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.15.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2020-07-27 11:00:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-07-27 19:54:00 +0100
commit411f47cdcb74109a103166477d606c88db6175ee (patch)
treeec6b9bd826e67b343e27161354a17648d1b454c0 /meta/recipes-devtools/json-c/json-c_0.15.bb
parenta8605c66ef5afe7c3583366781dfd90fe3526398 (diff)
downloadopenembedded-core-contrib-411f47cdcb74109a103166477d606c88db6175ee.tar.gz
json-c: update to 0.15
Remove upstreamed patch. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.15.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.15.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.15.bb b/meta/recipes-devtools/json-c/json-c_0.15.bb
new file mode 100644
index 0000000000..2968590dd8
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.15.bb
@@ -0,0 +1,18 @@
+SUMMARY = "C bindings for apps which will manipulate JSON data"
+DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
+HOMEPAGE = "https://github.com/json-c/json-c/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
+
+SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
+
+SRC_URI[sha256sum] = "b8d80a1ddb718b3ba7492916237bbf86609e9709fb007e7f7d4322f02341a4c6"
+
+UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
+UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+"
+
+RPROVIDES_${PN} = "libjson"
+
+inherit cmake
+
+BBCLASSEXTEND = "native nativesdk"