summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/jquery/jquery_3.5.0.bb
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2020-05-03 20:16:45 -0500
committerSteve Sakoman <steve@sakoman.com>2020-11-05 04:07:15 -1000
commit555cfcf53acf5e7ebe64874de33fa696670ce18c (patch)
tree5fc030181d21fef55a2db3f6c8a56ed427e97c37 /meta/recipes-devtools/jquery/jquery_3.5.0.bb
parente0201460f7888d220555e84ce2981ff5578114d4 (diff)
downloadopenembedded-core-contrib-555cfcf53acf5e7ebe64874de33fa696670ce18c.tar.gz
jquery: Upgrade 3.4.1 -> 3.5.0 to fix CVE-2020-11022 and CVE-2020-11023
Version 3.5.0 is a security release Reference: https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ The primary purpose of the jquery recipe is to make the diffoscope output from the autobuilder easier to navigate. Master branch has been using 3.5.X for some time now so this should be a safe upgrade. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit d0f883c4cbdcf722767b437a69002244be4cf8d9) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-devtools/jquery/jquery_3.5.0.bb')
-rw-r--r--meta/recipes-devtools/jquery/jquery_3.5.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/jquery/jquery_3.5.0.bb b/meta/recipes-devtools/jquery/jquery_3.5.0.bb
new file mode 100644
index 0000000000..5c6f9cddbe
--- /dev/null
+++ b/meta/recipes-devtools/jquery/jquery_3.5.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
+HOMEPAGE = "https://jquery.com/"
+LICENSE = "MIT"
+SECTION = "devel"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}.js;startline=8;endline=10;md5=b1e67ece919e852643f1541a54492d65"
+
+SRC_URI = "\
+ https://code.jquery.com/${BP}.js;name=js \
+ https://code.jquery.com/${BP}.min.js;name=min \
+ https://code.jquery.com/${BP}.min.map;name=map \
+ "
+
+SRC_URI[js.sha256sum] = "aff01a147aeccc9b70a5efad1f2362fd709f3316296ec460d94aa7d31decdb37"
+SRC_URI[min.sha256sum] = "c4dccdd9ae25b64078e0c73f273de94f8894d5c99e4741645ece29aeefc9c5a4"
+SRC_URI[map.sha256sum] = "3149351c8cbc3fb230bbf6188617c7ffda77d9e14333f4f5f0aa1aae379df892"
+
+UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${datadir}/javascript/${BPN}/
+ install -m 644 ${WORKDIR}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
+ install -m 644 ${WORKDIR}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
+ install -m 644 ${WORKDIR}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "${datadir}"
+
+BBCLASSEXTEND += "native nativesdk"