aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/intltool
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-08-12 08:31:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-15 15:13:34 +0100
commitd4b4ecb33c727ed54ab52de79e69cd3f0d14fb35 (patch)
tree3e6e26d73f2c1a70b79f0f56aa221ac78cac5fec /meta/recipes-devtools/intltool
parent2c036c71cf0d978fac2ddc4abfb702d42af6bcda (diff)
downloadopenembedded-core-contrib-d4b4ecb33c727ed54ab52de79e69cd3f0d14fb35.tar.gz
intltool: Use nativeperl binary for PERL instead of 'perl'
License is GPLv2 change it. Defining PERL for native intltool is not needed anymore Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/intltool')
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.40.6/use-nativeperl.patch20
-rw-r--r--meta/recipes-devtools/intltool/intltool.inc3
-rw-r--r--meta/recipes-devtools/intltool/intltool_0.40.6.bb9
3 files changed, 28 insertions, 4 deletions
diff --git a/meta/recipes-devtools/intltool/intltool-0.40.6/use-nativeperl.patch b/meta/recipes-devtools/intltool/intltool-0.40.6/use-nativeperl.patch
new file mode 100644
index 0000000000..5f5fed3853
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.40.6/use-nativeperl.patch
@@ -0,0 +1,20 @@
+OE has perl binary as 'nativeperl' in native sysroot so we look for it
+in order to avoid intltool searching and finding perl from /usr/bin
+on build system which may not have all the modules that it needs.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [OE specific]
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-08-09 08:07:16.427347846 -0700
+@@ -110,7 +110,7 @@
+ AC_MSG_ERROR([GNU gettext tools not found; required for intltool])
+ fi
+
+-AC_PATH_PROG(INTLTOOL_PERL, perl)
++AC_PATH_PROG(INTLTOOL_PERL, nativeperl)
+ if test -z "$INTLTOOL_PERL"; then
+ AC_MSG_ERROR([perl not found])
+ fi
diff --git a/meta/recipes-devtools/intltool/intltool.inc b/meta/recipes-devtools/intltool/intltool.inc
index 1e778b6f3e..7e11fc9da9 100644
--- a/meta/recipes-devtools/intltool/intltool.inc
+++ b/meta/recipes-devtools/intltool/intltool.inc
@@ -1,6 +1,6 @@
DESCRIPTION = "Utility scripts for internationalizing XML"
SECTION = "devel"
-LICENSE = "GPL"
+LICENSE = "GPLv2"
URLV="${@'.'.join(bb.data.getVar('PV',d,1).split('.')[0:2])}"
SRC_URI = "${GNOME_MIRROR}/intltool/${URLV}/intltool-${PV}.tar.bz2"
@@ -13,5 +13,4 @@ RRECOMMENDS_${PN}_virtclass-native = ""
inherit autotools pkgconfig perlnative
-export PERL_virtclass-native = "/usr/bin/env perl"
BBCLASSEXTEND = "native"
diff --git a/meta/recipes-devtools/intltool/intltool_0.40.6.bb b/meta/recipes-devtools/intltool/intltool_0.40.6.bb
index c7938e5d36..931122dac2 100644
--- a/meta/recipes-devtools/intltool/intltool_0.40.6.bb
+++ b/meta/recipes-devtools/intltool/intltool_0.40.6.bb
@@ -1,9 +1,14 @@
require intltool.inc
LICENSE="GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r3"
+PR = "r4"
-SRC_URI_append = " file://intltool-nowarn-0.40.0.patch"
+SRC_URI_append = " file://intltool-nowarn-0.40.0.patch \
+ ${NATIVEPATCHES} \
+ "
+
+NATIVEPATCHES = ""
+NATIVEPATCHES_virtclass-native = "file://use-nativeperl.patch"
SRC_URI[md5sum] = "69bc0353323112f42ad4f9cf351bc3e5"
SRC_URI[sha256sum] = "4d1e5f8561f09c958e303d4faa885079a5e173a61d28437d0013ff5efc9e3b64"