aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/intltool/intltool-0.50.2
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-02-05 18:13:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:04 +0000
commitf0f5507f30b5d8d919e93cb6af6b724981e9cfef (patch)
tree062c4b6ae44f7e5e20ac3b101e175e06a4d2a5be /meta/recipes-devtools/intltool/intltool-0.50.2
parenta5136a9bf70f3a6d7d0b599678cb901c8e45c7f7 (diff)
downloadopenembedded-core-contrib-f0f5507f30b5d8d919e93cb6af6b724981e9cfef.tar.gz
intltool: updated to 0.50.2
Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/intltool/intltool-0.50.2')
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.50.2/intltool-nowarn.patch42
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch40
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.50.2/remove-xml-check.patch33
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.50.2/use-nativeperl.patch20
4 files changed, 135 insertions, 0 deletions
diff --git a/meta/recipes-devtools/intltool/intltool-0.50.2/intltool-nowarn.patch b/meta/recipes-devtools/intltool/intltool-0.50.2/intltool-nowarn.patch
new file mode 100644
index 0000000000..06c938b7e3
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.50.2/intltool-nowarn.patch
@@ -0,0 +1,42 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Index: intltool-0.40.0/intltool-extract.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-extract.in 2011-10-08 22:24:57.000000000 +0300
++++ intltool-0.50.0/intltool-extract.in 2011-12-07 16:04:07.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ #
+Index: intltool-0.50.0/intltool-merge.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-merge.in 2011-10-08 17:52:01.000000000 +0300
++++ intltool-0.50.0/intltool-merge.in 2011-12-07 16:05:55.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ #
+Index: intltool-0.50.0/intltool-prepare.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-prepare.in 2011-10-08 09:16:58.000000000 +0300
++++ intltool-0.50.0/intltool-prepare.in 2011-12-07 16:06:13.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ # Intltool .desktop, .directory Prepare Tool
+Index: intltool-0.50.0/intltool-update.in
+===================================================================
+--- intltool-0.50.0.orig/intltool-update.in 2011-10-08 22:24:57.000000000 +0300
++++ intltool-0.50.0/intltool-update.in 2011-12-07 16:06:39.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!@INTLTOOL_PERL@ -w
++#!@INTLTOOL_PERL@
+ # -*- Mode: perl; indent-tabs-mode: nil; c-basic-offset: 4 -*-
+
+ #
diff --git a/meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch b/meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch
new file mode 100644
index 0000000000..853ee1a438
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch
@@ -0,0 +1,40 @@
+In the target case, we can't check if perl exists or try running it. If we
+don't patch the code, the native perl location would be used, not the target
+which is also incorrect. We therefore disable this code and rely on the
+correct value of PERL being passed in.
+
+RP 31/8/2011
+
+Upstream-Status: Inappropriate [OE specific]
+
+diff --git a/configure.ac b/configure.ac
+index 5338a76..e709a2b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,24 +11,10 @@ AC_SUBST(pkgdatadir) dnl automake does not need this, but libtoolize does
+ aclocaldir='${datadir}'/aclocal
+ AC_SUBST(aclocaldir)
+
+-AC_PATH_PROG(PERL, perl)
+ if test -z "$PERL"; then
+- AC_MSG_ERROR([perl not found])
+-fi
+-AC_MSG_CHECKING([for perl >= 5.8.1])
+-$PERL -e "use 5.8.1;" > /dev/null 2>&1
+-if test $? -ne 0; then
+- AC_MSG_ERROR([perl 5.8.1 is required for intltool])
+-else
+- PERL_VERSION="`$PERL -e \"printf '%vd', $^V\"`"
+- AC_MSG_RESULT([$PERL_VERSION])
+-fi
+-AC_MSG_CHECKING([for XML::Parser])
+-if `$PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+-else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++ AC_MSG_ERROR([PERL variable not set])
+ fi
++AC_SUBST(PERL)
+ AC_PATH_PROG(BZR, bzr)
+
+
diff --git a/meta/recipes-devtools/intltool/intltool-0.50.2/remove-xml-check.patch b/meta/recipes-devtools/intltool/intltool-0.50.2/remove-xml-check.patch
new file mode 100644
index 0000000000..fc69e37b45
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.50.2/remove-xml-check.patch
@@ -0,0 +1,33 @@
+Signed-off-by: Florin Sarbu <florin.sarbu@windriver.com>
+
+Upstream-Status: Inappropriate [OE specific]
+
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-11-23 15:39:34.689561872 -0800
+@@ -122,14 +122,16 @@
+ IT_PERL_VERSION="`$INTLTOOL_PERL -e \"printf '%vd', $^V\"`"
+ AC_MSG_RESULT([$IT_PERL_VERSION])
+ fi
+-if test "x$2" != "xno-xml"; then
+- AC_MSG_CHECKING([for XML::Parser])
+- if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+- else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
+- fi
+-fi
++
++# Disable this check since we know XML::Parser is installed
++#if test "x$2" != "xno-xml"; then
++# AC_MSG_CHECKING([for XML::Parser])
++# if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
++# AC_MSG_RESULT([ok])
++# else
++# AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++# fi
++#fi
+
+ # Substitute ALL_LINGUAS so we can use it in po/Makefile
+ AC_SUBST(ALL_LINGUAS)
diff --git a/meta/recipes-devtools/intltool/intltool-0.50.2/use-nativeperl.patch b/meta/recipes-devtools/intltool/intltool-0.50.2/use-nativeperl.patch
new file mode 100644
index 0000000000..5f5fed3853
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.50.2/use-nativeperl.patch
@@ -0,0 +1,20 @@
+OE has perl binary as 'nativeperl' in native sysroot so we look for it
+in order to avoid intltool searching and finding perl from /usr/bin
+on build system which may not have all the modules that it needs.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [OE specific]
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-08-09 08:07:16.427347846 -0700
+@@ -110,7 +110,7 @@
+ AC_MSG_ERROR([GNU gettext tools not found; required for intltool])
+ fi
+
+-AC_PATH_PROG(INTLTOOL_PERL, perl)
++AC_PATH_PROG(INTLTOOL_PERL, nativeperl)
+ if test -z "$INTLTOOL_PERL"; then
+ AC_MSG_ERROR([perl not found])
+ fi