aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-02-05 18:13:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:04 +0000
commitf0f5507f30b5d8d919e93cb6af6b724981e9cfef (patch)
tree062c4b6ae44f7e5e20ac3b101e175e06a4d2a5be /meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch
parenta5136a9bf70f3a6d7d0b599678cb901c8e45c7f7 (diff)
downloadopenembedded-core-contrib-f0f5507f30b5d8d919e93cb6af6b724981e9cfef.tar.gz
intltool: updated to 0.50.2
Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch')
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch b/meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch
new file mode 100644
index 0000000000..853ee1a438
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch
@@ -0,0 +1,40 @@
+In the target case, we can't check if perl exists or try running it. If we
+don't patch the code, the native perl location would be used, not the target
+which is also incorrect. We therefore disable this code and rely on the
+correct value of PERL being passed in.
+
+RP 31/8/2011
+
+Upstream-Status: Inappropriate [OE specific]
+
+diff --git a/configure.ac b/configure.ac
+index 5338a76..e709a2b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,24 +11,10 @@ AC_SUBST(pkgdatadir) dnl automake does not need this, but libtoolize does
+ aclocaldir='${datadir}'/aclocal
+ AC_SUBST(aclocaldir)
+
+-AC_PATH_PROG(PERL, perl)
+ if test -z "$PERL"; then
+- AC_MSG_ERROR([perl not found])
+-fi
+-AC_MSG_CHECKING([for perl >= 5.8.1])
+-$PERL -e "use 5.8.1;" > /dev/null 2>&1
+-if test $? -ne 0; then
+- AC_MSG_ERROR([perl 5.8.1 is required for intltool])
+-else
+- PERL_VERSION="`$PERL -e \"printf '%vd', $^V\"`"
+- AC_MSG_RESULT([$PERL_VERSION])
+-fi
+-AC_MSG_CHECKING([for XML::Parser])
+-if `$PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+-else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++ AC_MSG_ERROR([PERL variable not set])
+ fi
++AC_SUBST(PERL)
+ AC_PATH_PROG(BZR, bzr)
+
+