aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-11-23 15:47:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-29 11:19:53 +0000
commit264fb6c5a4875cd8969a24a9f0301ed916ab827b (patch)
tree6dec24af9f4174575c25b6222ffd8d12bedc0502 /meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch
parent8b7643c5c06c1b1531e55a49cd69502b146a92bd (diff)
downloadopenembedded-core-contrib-264fb6c5a4875cd8969a24a9f0301ed916ab827b.tar.gz
intltool: remove XML::Parser check
Add Patch to disable the XML::Parser check in the target intltool.m4, this check will find the host (not native) XML::Parser if it's installed possibly causing Host contamination, but will also fail configuration if XML::Parser is not installed on the host. Since we know that XML::Parser is installed on the image, we don't really need this check, so comment it out. From RP in mail thread: > If the recipe needs perl for > some other reason than intltool, it needs perlnative but it if only > needs perl for intltool, we shouldn't need the dependency. The .m4 macro > checks are well intended but don't fit the way we use perl. I really > don't want to end up in a position where intltool automatically means we > have to add perlnative as a dependency and we've previously seen many > problems related to that. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch')
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch b/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch
new file mode 100644
index 0000000000..476d0913d4
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch
@@ -0,0 +1,29 @@
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-11-23 15:39:34.689561872 -0800
+@@ -122,14 +122,16 @@
+ IT_PERL_VERSION="`$INTLTOOL_PERL -e \"printf '%vd', $^V\"`"
+ AC_MSG_RESULT([$IT_PERL_VERSION])
+ fi
+-if test "x$2" != "xno-xml"; then
+- AC_MSG_CHECKING([for XML::Parser])
+- if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+- else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
+- fi
+-fi
++
++# Disable this check since we know XML::Parser is installed
++#if test "x$2" != "xno-xml"; then
++# AC_MSG_CHECKING([for XML::Parser])
++# if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
++# AC_MSG_RESULT([ok])
++# else
++# AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++# fi
++#fi
+
+ # Substitute ALL_LINGUAS so we can use it in po/Makefile
+ AC_SUBST(ALL_LINGUAS)