aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/insserv/files/crosscompile_fix.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-devtools/insserv/files/crosscompile_fix.patch
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-contrib-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/insserv/files/crosscompile_fix.patch')
-rw-r--r--meta/recipes-devtools/insserv/files/crosscompile_fix.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/insserv/files/crosscompile_fix.patch b/meta/recipes-devtools/insserv/files/crosscompile_fix.patch
new file mode 100644
index 0000000000..14d8db468f
--- /dev/null
+++ b/meta/recipes-devtools/insserv/files/crosscompile_fix.patch
@@ -0,0 +1,22 @@
+Index: insserv-1.11.0/Makefile
+===================================================================
+--- insserv-1.11.0.orig/Makefile 2008-08-25 16:00:00.000000000 +0100
++++ insserv-1.11.0/Makefile 2008-08-25 16:00:25.000000000 +0100
+@@ -18,16 +18,7 @@
+ #
+ # Architecture
+ #
+-ifdef RPM_OPT_FLAGS
+- COPTS = -g $(RPM_OPT_FLAGS)
+-else
+- ARCH = $(shell uname -i)
+-ifeq ($(ARCH),i386)
+- COPTS = -O2 -mcpu=i586 -mtune=i686
+-else
+- COPTS = -O2
+-endif
+-endif
++COPTS = -O2
+ COPTS += -g
+
+ MY_CFLAGS = $(CFLAGS) -Wall $(COPTS) $(DEBUG) $(LOOPS) -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \