aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/files/guile_2.0.6_fix_sed_error.patch
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2012-07-31 15:33:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-02 16:34:01 +0100
commit310f169d3d89f3a4fc6a540974a30c7eb565db3a (patch)
tree26e6ae584068aca5c74202df6ca356e4107bec77 /meta/recipes-devtools/guile/files/guile_2.0.6_fix_sed_error.patch
parent8329c4679ec0ce319d2a81d755a0da5b05474688 (diff)
downloadopenembedded-core-contrib-310f169d3d89f3a4fc6a540974a30c7eb565db3a.tar.gz
guile: updated to 2.0.6
Some patches (disable_goops_optimizations, fix_cross_compilation) don't seem to be needed anymore. Others (change-install-data-hook, mark-unused-modules) were updated to work on 2.0.6. Tested by building and running guile under QEMU with core-image-sato-sdk and also builing guile on MIPS. Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile/files/guile_2.0.6_fix_sed_error.patch')
-rw-r--r--meta/recipes-devtools/guile/files/guile_2.0.6_fix_sed_error.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/guile/files/guile_2.0.6_fix_sed_error.patch b/meta/recipes-devtools/guile/files/guile_2.0.6_fix_sed_error.patch
new file mode 100644
index 0000000000..e5dc226370
--- /dev/null
+++ b/meta/recipes-devtools/guile/files/guile_2.0.6_fix_sed_error.patch
@@ -0,0 +1,24 @@
+Upstream-Status: Pending
+
+This fixes sed issue when prefix has / in it, like /usr/local
+
+autoreconf error avoided:
+| sed: -e expression #1, char 9: unknown option to `s'
+| configure.ac:39: error: AC_INIT should be called with package and version arguments
+
+Signed-Off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/05/01
+
+Index: guile-2.0.5/build-aux/git-version-gen
+===================================================================
+--- guile-2.0.5.orig/build-aux/git-version-gen
++++ guile-2.0.5/build-aux/git-version-gen
+@@ -187,7 +187,7 @@ else
+ v=UNKNOWN
+ fi
+
+-v=`echo "$v" |sed "s/^$prefix//"`
++v=`echo "$v" |sed "s#^$prefix##"`
+
+ # Test whether to append the "-dirty" suffix only if the version
+ # string we're using came from git. I.e., skip the test if it's "UNKNOWN"