summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-01-17 13:59:32 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-17 16:35:08 +0000
commitd5e1003283f21ed0b3bbe594b24eb4fa1dd27956 (patch)
tree72edee989baccc523a1d0e2f505fdfd8d8ddd62b /meta/recipes-devtools/go
parenta776a8190d5abee97da8684d4c448e3ed7bb7fb8 (diff)
downloadopenembedded-core-contrib-d5e1003283f21ed0b3bbe594b24eb4fa1dd27956.tar.gz
go-dep: upgrade 0.3.1 -> 0.3.2
The 0.3.2 version has been released in Oct 19, 2017, and has a great set of features and improvements, as seen in the announcement summary: ,---- | NEW FEATURES: | | - Add support for importing from gvt and gb. (#1149) | - Wildcard ignore support. (#1156) | - Disable SourceManager lock by setting DEPNOLOCK environment | variable. (#1206) | - dep ensure -no-vendor -dry-run now exits with an error when | changes would have to be made to Gopkg.lock. This is useful | for CI. (#1256) | | BUG FIXES: | | - gps: Fix case mismatch error with multiple dependers. (#1233) | - Skip broken vendor symlink rather than returning an error. (#1191) | - Fix status shows incorrect reason for lock mismatch when ignoring | packages. (#1216) | | IMPROVEMENTS: | | - Allow dep ensure -add and -update when lock is out-of-sync. (#1225) | - gps: vcs: Dedupe git version list (#1212) | - gps: Add prune functions to gps. (#1020) | - gps: Skip broken vendor symlinks. (#1191) | - dep ensure -add now concurrently fetches the source and adds the | projects. (#1218) | - File name case check is now performed on Gopkg.toml and Gopkg.lock. | (#1114) | - gps: gps now supports pruning. (#1020) | - dep ensure -update now concurrently validates the passed project | arguments. Improving performance when updating dependencies with | -update. (#1175) | - dep status now concurrently fetches repo info. Improving status | performance. (#1135) | - gps: Add SourceURLsForPath() to SourceManager. (#1166) | - gps: Include output in error. (#1180) `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go')
-rw-r--r--meta/recipes-devtools/go/go-dep_0.3.2.bb (renamed from meta/recipes-devtools/go/go-dep_0.3.1.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.3.1.bb b/meta/recipes-devtools/go/go-dep_0.3.2.bb
index 3a404e357f..627324a1df 100644
--- a/meta/recipes-devtools/go/go-dep_0.3.1.bb
+++ b/meta/recipes-devtools/go/go-dep_0.3.2.bb
@@ -9,8 +9,8 @@ SRC_URI = "git://${GO_IMPORT} \
file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
"
-# Points to 0.3.1 tag
-SRCREV = "83789e236d7ff64c82ee8392005455fc1ec1983b"
+# Points to 0.3.2 tag
+SRCREV = "8ddfc8afb2d520d41997ebddd921b52152706c01"
inherit go