summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.9.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-07 16:10:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-09 14:41:20 +0000
commit277162917331b235863eec31cbe82c101f0e4efe (patch)
treee344e8e3b2366d57326803d2f43c6fe3b6ed1cf7 /meta/recipes-devtools/go/go_1.9.bb
parentf559fd6df2978f9093672794420eada2b7452987 (diff)
downloadopenembedded-core-contrib-277162917331b235863eec31cbe82c101f0e4efe.tar.gz
go-1.9: Drop the recipes
We now have 1.11 and 1.12 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.9.bb28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta/recipes-devtools/go/go_1.9.bb b/meta/recipes-devtools/go/go_1.9.bb
deleted file mode 100644
index c23ea0c1ae..0000000000
--- a/meta/recipes-devtools/go/go_1.9.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-require go-${PV}.inc
-require go-target.inc
-
-export GO_TARGET_INSTALL = "cmd"
-export GO_FLAGS = "-a"
-export CC_FOR_TARGET = "${CC}"
-export CXX_FOR_TARGET = "${CXX}"
-export GOBUILDMODE=""
-
-do_compile() {
- export GOBIN="${B}/bin"
- export TMPDIR="$GOTMPDIR"
- export CC=$BUILD_CC
-
- cd src
- ./make.bash
- cd ${B}
-}
-
-# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
-# doesn't support -buildmode=pie, so skip the QA checking for mips and its
-# variants.
-python() {
- if 'mips' in d.getVar('TARGET_ARCH'):
- d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
- else:
- d.setVar('GOBUILDMODE', 'pie')
-}