summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-binary-native_1.15.5.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-21 00:23:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-24 10:27:39 +0000
commita71d1b58e8cf0976a614c49aa2dfe1e0605dfe95 (patch)
tree4969120988e239fe9fb728a4ec62c06dae5effd9 /meta/recipes-devtools/go/go-binary-native_1.15.5.bb
parent9bb06428cbb2ac0f3d98a1696f050d3393385503 (diff)
downloadopenembedded-core-contrib-a71d1b58e8cf0976a614c49aa2dfe1e0605dfe95.tar.gz
go: Update to 1.15.5
Define CXX_FOR_TARGET and CC_FOR_TARGET for target go since we are cross building it, it helps in defining the compiler for cgo on target backport a patch to fix CGO_LDFLAGS regression like below Fixes | Building std for target, linux/arm. | go build runtime/cgo: invalid flag in go:cgo_ldflag: -Wl,-O1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-binary-native_1.15.5.bb')
-rw-r--r--meta/recipes-devtools/go/go-binary-native_1.15.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.15.5.bb b/meta/recipes-devtools/go/go-binary-native_1.15.5.bb
new file mode 100644
index 0000000000..1fb11b0435
--- /dev/null
+++ b/meta/recipes-devtools/go/go-binary-native_1.15.5.bb
@@ -0,0 +1,46 @@
+# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
+
+SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
+HOMEPAGE = " http://golang.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
+
+PROVIDES = "go-native"
+
+SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
+SRC_URI[go_linux_amd64.sha256sum] = "9a58494e8da722c3aef248c9227b0e9c528c7318309827780f16220998180a0d"
+SRC_URI[go_linux_arm64.sha256sum] = "a72a0b036beb4193a0214bca3fca4c5d68a38a4ccf098c909f7ce8bf08567c48"
+
+UPSTREAM_CHECK_URI = "https://golang.org/dl/"
+UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
+
+S = "${WORKDIR}/go"
+
+inherit goarch native
+
+do_compile() {
+ :
+}
+
+make_wrapper() {
+ rm -f ${D}${bindir}/$1
+ cat <<END >${D}${bindir}/$1
+#!/bin/bash
+here=\`dirname \$0\`
+export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
+\$here/../lib/go/bin/$1 "\$@"
+END
+ chmod +x ${D}${bindir}/$1
+}
+
+do_install() {
+ find ${S} -depth -type d -name testdata -exec rm -rf {} +
+
+ install -d ${D}${bindir} ${D}${libdir}/go
+ cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
+
+ for f in ${S}/bin/*
+ do
+ make_wrapper `basename $f`
+ done
+}