aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gnu-config/gnu-config_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 12:42:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 12:45:53 +0000
commit4a601314604e8428d9dace95c32a71a57eacaaf5 (patch)
treef466b224b51b8a8a56f578534a6d1876b0195100 /meta/recipes-devtools/gnu-config/gnu-config_git.bb
parent19266bcaae3ee4588e2da1e76a1066f2a150f371 (diff)
downloadopenembedded-core-contrib-4a601314604e8428d9dace95c32a71a57eacaaf5.tar.gz
gnu-config: Only apply path transformations in the non-native/non-nativesdk case
The BUILD_ARCH != TARGET_ARCH check isn't a safe one to detect native builds and doesn't cover the nativesdk case. This converts the recipe to use PN instead which is more accurate and ensures the correct entries making it into the correct packages. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gnu-config/gnu-config_git.bb')
-rw-r--r--meta/recipes-devtools/gnu-config/gnu-config_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gnu-config/gnu-config_git.bb b/meta/recipes-devtools/gnu-config/gnu-config_git.bb
index 0fdee66ba4..4de479915b 100644
--- a/meta/recipes-devtools/gnu-config/gnu-config_git.bb
+++ b/meta/recipes-devtools/gnu-config/gnu-config_git.bb
@@ -29,7 +29,7 @@ do_install () {
sed -e 's,@gnu-configdir@,${datadir}/gnu-config,g' \
-e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize
# In the native case we want the system perl as perl-native can't have built yet
- if [ "${BUILD_ARCH}" != "${TARGET_ARCH}" ]; then
+ if [ "${PN}" != "gnu-config-native" -a "${PN}" != "gnu-config-nativesdk" ]; then
sed -i -e 's,/usr/bin/env,${bindir}/env,g' ${D}${bindir}/gnu-configize
fi
chmod 755 ${D}${bindir}/gnu-configize