aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.11.1.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-11-02 15:57:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:23 +0000
commit371345c0dc49bf781c27aea1e9f6a4c947fa30e6 (patch)
treed1fb7e8f3c109d9a71dcfe4a8ad6f580c3da17af /meta/recipes-devtools/gdb/gdb_7.11.1.bb
parent1ba6101ceaee354816e690d44bc9a5dd8dcf4011 (diff)
downloadopenembedded-core-contrib-371345c0dc49bf781c27aea1e9f6a4c947fa30e6.tar.gz
gdb: update 7.11+git1a982b689c -> 7.11.1
41d8236 Set GDB version number to 7.11.1. 136613e Fix PR gdb/19828: gdb -p <process from a container>: internal error a0de87e Make gdb/linux-nat.c consider a waitstatus pending on the infrun side cf2cd51 Add mi-threads-interrupt.exp test (PR 20039) f0a8d0d Fix double prompt output after run control MI commands with mi-async on (PR 20045) b5f0db4 Fix -exec-run not running asynchronously with mi-async on (PR gdb/18077) 7f8e34d Use target_terminal_ours_for_output in MI Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.11.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.1.bb b/meta/recipes-devtools/gdb/gdb_7.11.1.bb
new file mode 100644
index 0000000000..57cffc9983
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.11.1.bb
@@ -0,0 +1,26 @@
+require gdb.inc
+require gdb-${PV}.inc
+
+inherit python3-dir
+
+EXTRA_OEMAKE_append_libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ "
+
+do_configure_prepend() {
+ if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
+ cat > ${WORKDIR}/python << EOF
+#!/bin/sh
+case "\$2" in
+ --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
+ --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
+ --exec-prefix) echo "${exec_prefix}" ;;
+ *) exit 1 ;;
+esac
+exit 0
+EOF
+ chmod +x ${WORKDIR}/python
+ fi
+}
+CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"