summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-04 15:58:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-05 11:16:41 +0100
commit6d284d656e129be526e272f61405d1b004fe0ec9 (patch)
tree5ee929a3f0305da2b2a314188a614c83100d58e1 /meta/recipes-devtools/gcc
parent7e85b21e5fa8e6b61377ae830a95ebc7cd8fbd11 (diff)
downloadopenembedded-core-contrib-6d284d656e129be526e272f61405d1b004fe0ec9.tar.gz
gcc: Remove unneeded module .la file and .so link
This avoids a QA error. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-package-target.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc_4.5.1.bb2
3 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.6.inc b/meta/recipes-devtools/gcc/gcc-4.6.inc
index 68449954af..a880111cbd 100644
--- a/meta/recipes-devtools/gcc/gcc-4.6.inc
+++ b/meta/recipes-devtools/gcc/gcc-4.6.inc
@@ -1,6 +1,6 @@
require gcc-common.inc
-PR = "r5"
+PR = "r6"
# Third digit in PV should be incremented after a minor release
# happens from this branch on gcc e.g. currently its 4.6.0
diff --git a/meta/recipes-devtools/gcc/gcc-package-target.inc b/meta/recipes-devtools/gcc/gcc-package-target.inc
index 6cc308c6dc..8c66c72ac9 100644
--- a/meta/recipes-devtools/gcc/gcc-package-target.inc
+++ b/meta/recipes-devtools/gcc/gcc-package-target.inc
@@ -72,6 +72,8 @@ do_install () {
# Cleanup some of the ${libdir}{,exec}/gcc stuff ...
rm -r ${D}${libdir}/gcc/${TARGET_SYS}/${BINV}/install-tools
rm -r ${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/install-tools
+ rm -r ${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/*.so
+ rm -r ${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/*.la
# Hack around specs file assumptions
test -f ${D}${libdir}/gcc/${TARGET_SYS}/${BINV}/specs && sed -i -e '/^*cross_compile:$/ { n; s/1/0/; }' ${D}${libdir}/gcc/${TARGET_SYS}/${BINV}/specs
diff --git a/meta/recipes-devtools/gcc/gcc_4.5.1.bb b/meta/recipes-devtools/gcc/gcc_4.5.1.bb
index 785d719ac8..12e42c4dcf 100644
--- a/meta/recipes-devtools/gcc/gcc_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/gcc_4.5.1.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc