aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_5.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-12-14 06:23:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-22 16:08:42 +0000
commit8b664a7d6bba89a8221d7fd1a52915fef0002d71 (patch)
tree102d164a58bdf57a43951415cf0974afeec625a7 /meta/recipes-devtools/gcc/gcc_5.3.bb
parent2a1edfd9cfa16ec334c0758b47677d4fee5e79a8 (diff)
downloadopenembedded-core-contrib-8b664a7d6bba89a8221d7fd1a52915fef0002d71.tar.gz
gcc5: Upgrade gcc-5.2 -> gcc-5.3
Minor bugfix upgrade to gcc 5.3 for detailed list of fixes in 5.3 see https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&list_id=132738&resolution=FIXED&target_milestone=5.3 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_5.3.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_5.3.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_5.3.bb b/meta/recipes-devtools/gcc/gcc_5.3.bb
new file mode 100644
index 0000000000..b0a523cae2
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_5.3.bb
@@ -0,0 +1,15 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require gcc-target.inc
+
+# Building with thumb enabled on armv4t fails with
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
+ARM_INSTRUCTION_SET_armv4 = "arm"
+
+do_configure_prepend() {
+ # Easiest way to stop bad RPATHs getting into the library since we have a
+ # broken libtool here
+ sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${S}/libcc1/configure
+}
+
+BBCLASSEXTEND = "nativesdk"