summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-02-06 10:13:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-08 10:58:31 +0000
commitd740530daf4ad4e67a323bf39e968e930f208543 (patch)
treea83e09983c68e442f6f5ae79755733c93c4c96bf /meta/recipes-devtools/file
parent0e4bde86e1aa499274fc85d01d36a74c3401762e (diff)
downloadopenembedded-core-contrib-d740530daf4ad4e67a323bf39e968e930f208543.tar.gz
file: enable additional internal compressor support
This is an extension of https://git.yoctoproject.org/poky/commit/meta/recipes-devtools/file?h=master&id=52a31bd5ba90713af82822047c3813afc31421f8 and the rationale is the same. The issue was exposed by recent ptest support in xz, which packages .lz files into the xz-ptest package which resulted in reproducibility fails: http://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20240203-fdpg888c/packages/diff-html/ Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file')
-rw-r--r--meta/recipes-devtools/file/file_5.45.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/file/file_5.45.bb b/meta/recipes-devtools/file/file_5.45.bb
index 8477668658..fa8dc576dc 100644
--- a/meta/recipes-devtools/file/file_5.45.bb
+++ b/meta/recipes-devtools/file/file_5.45.bb
@@ -20,12 +20,12 @@ S = "${WORKDIR}/git"
inherit autotools update-alternatives
-PACKAGECONFIG ??= "bz2 lzma zlib"
+PACKAGECONFIG ??= "bz2 lzma zlib zstdlib lzlib"
PACKAGECONFIG[bz2] = "--enable-bzlib, --disable-bzlib, bzip2"
PACKAGECONFIG[lzma] = "--enable-xzlib, --disable-xzlib, xz"
PACKAGECONFIG[zlib] = "--enable-zlib, --disable-zlib, zlib"
PACKAGECONFIG[zstdlib] = "--enable-zstdlib, --disable-zstdlib, zstd"
-PACKAGECONFIG[lzlib] = "--enable-lzlib, --disable-lzlib, lzip"
+PACKAGECONFIG[lzlib] = "--enable-lzlib, --disable-lzlib, lzlib"
PACKAGECONFIG[seccomp] = "--enable-libseccomp, --disable-libseccomp, libseccomp"
ALTERNATIVE:${PN} = "file"