aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.23.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-24 01:55:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-01 15:38:20 +0100
commit91db51363b3cf78a7b908ea4a548ab9658150661 (patch)
tree146f9081b3c056b7b9f11d044301ed2c6ea4e4fb /meta/recipes-devtools/file/file_5.23.bb
parent742e0fa636d4792d1fad088bed3c194fb4374e91 (diff)
downloadopenembedded-core-contrib-91db51363b3cf78a7b908ea4a548ab9658150661.tar.gz
file: 5.22 -> 5.23
Updated 0001-Add-P-prompt-into-Usage-info.patch. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.23.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.23.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.23.bb b/meta/recipes-devtools/file/file_5.23.bb
new file mode 100644
index 0000000000..d71f29056c
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.23.bb
@@ -0,0 +1,36 @@
+SUMMARY = "File classification tool"
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+HOMEPAGE = "http://www.darwinsys.com/file/"
+SECTION = "console/utils"
+
+# two clause BSD
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
+
+DEPENDS = "zlib file-native"
+DEPENDS_class-native = "zlib-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/${BP}.tar.gz \
+ file://debian-742262.patch \
+ file://0001-Add-P-prompt-into-Usage-info.patch \
+ "
+
+SRC_URI[md5sum] = "61db35209ce71a6d576392ce6e1d2f80"
+SRC_URI[sha256sum] = "2c8ab3ff143e2cdfb5ecee381752f80a79e0b4cfe9ca4cc6e1c3e5ec15e6157c"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/misc/*.mgc"
+
+do_install_append_class-native() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
+
+do_install_append_class-nativesdk() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
+
+BBCLASSEXTEND = "native nativesdk"