aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.21.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-12-21 21:28:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-22 10:53:56 +0000
commit9f336e07df7e273c55f0c7a451604a3500b4c6ab (patch)
treea4b04cc2ed6a85b942bd8e1ddd20d9b8aaaa4ee9 /meta/recipes-devtools/file/file_5.21.bb
parent31e259f2f2a83c26b8a62b6d7dbca010c6db16bf (diff)
downloadopenembedded-core-contrib-9f336e07df7e273c55f0c7a451604a3500b4c6ab.tar.gz
file: upgrade to 5.21
* Upgrade to 5.21. * The debian-742262.patch is still needed. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.21.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.21.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.21.bb b/meta/recipes-devtools/file/file_5.21.bb
new file mode 100644
index 0000000000..702ea87343
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.21.bb
@@ -0,0 +1,35 @@
+SUMMARY = "File classification tool"
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+HOMEPAGE = "http://www.darwinsys.com/file/"
+SECTION = "console/utils"
+
+# two clause BSD
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
+
+DEPENDS = "zlib file-native"
+DEPENDS_class-native = "zlib-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
+ file://debian-742262.patch \
+ "
+
+SRC_URI[md5sum] = "549fe96e09041eabece9de2bb28ef923"
+SRC_URI[sha256sum] = "1a48741d3923c4cc73267109b8a396c0ce3aebe004181f3efb1b0a228d230bb6"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/misc/*.mgc"
+
+do_install_append_class-native() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
+
+do_install_append_class-nativesdk() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
+
+BBCLASSEXTEND = "native nativesdk"