aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-16 17:04:02 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-27 11:26:56 +0000
commit1d82a2cfa1c5243d0e5a600a2aa063f1a7a667ba (patch)
treecc368fbefaf51d836bf23c88af75cbd2591b0742 /meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
parent762b3111f3124ee75404835da751fb95b8466fd4 (diff)
downloadopenembedded-core-contrib-1d82a2cfa1c5243d0e5a600a2aa063f1a7a667ba.tar.gz
gptfdisk: update to 1.0.1
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb')
-rw-r--r--meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb b/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
new file mode 100644
index 0000000000..9f1daf3603
--- /dev/null
+++ b/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Utility for modifying GPT disk partitioning"
+DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+DEPENDS = "util-linux popt ncurses"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz"
+SRC_URI[md5sum] = "d7f3d306b083123bcc6f5941efade586"
+SRC_URI[sha256sum] = "864c8aee2efdda50346804d7e6230407d5f42a8ae754df70404dd8b2fdfaeac7"
+
+UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
+UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 cgdisk ${D}${sbindir}
+ install -m 0755 gdisk ${D}${sbindir}
+ install -m 0755 sgdisk ${D}${sbindir}
+ install -m 0755 fixparts ${D}${sbindir}
+}
+
+BBCLASSEXTEND = "native nativesdk"