aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-01-23 15:17:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-26 10:41:11 +0000
commit4b43aab5b2043a5b83ef1fa9a8406f8a46ccfa72 (patch)
treef0773020fa8c96b38cce2c3c9f9002a9288e03a8 /meta/recipes-devtools/expect
parentcb0ef6e5fe096cecade81d42e95918f056bba052 (diff)
downloadopenembedded-core-contrib-4b43aab5b2043a5b83ef1fa9a8406f8a46ccfa72.tar.gz
expect: support native compilation
This is needed for building the swtpm TPM simulator (recipe in meta-security). "nativesdk" is added just in case that someone also wants this in an SDK. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/expect')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
index b4dfe157ce..ab22a61394 100644
--- a/meta/recipes-devtools/expect/expect_5.45.bb
+++ b/meta/recipes-devtools/expect/expect_5.45.bb
@@ -43,11 +43,16 @@ do_install_append() {
sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl
}
+# Apparently the public Tcl headers are only in /usr/include/tcl8.6
+# when building for the target.
+TCL_INCLUDE_PATH = ""
+TCL_INCLUDE_PATH_class-target = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
+
EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
- --with-tclinclude=${STAGING_INCDIR}/tcl8.6 \
--enable-shared \
--enable-threads \
--disable-rpath \
+ ${TCL_INCLUDE_PATH} \
"
EXTRA_OEMAKE_install = " 'SCRIPTS=' "
@@ -62,3 +67,5 @@ FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
FILES_${PN} += "${libdir}/libexpect${PV}.so \
${libdir}/expect${PV}/* \
"
+
+BBCLASSEXTEND = "native nativesdk"