summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect/expect
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-03-18 15:12:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-19 14:19:45 +0000
commita8fe5fd62fd98e33180f3de700ed01f9efb74a50 (patch)
tree63d3316455d7f06f9c45d1f54cec4bb433ef920a /meta/recipes-devtools/expect/expect
parentc9899a7605f15f7f1ae30c4624d53c7da825b00a (diff)
downloadopenembedded-core-contrib-a8fe5fd62fd98e33180f3de700ed01f9efb74a50.tar.gz
expect: fix do_install failure on SLED 11.2
Previously we were encountering do_install failures on older machines like SLED 11.2. These machines have relatively lower versions of glibc. tclsh8.6: /lib64/libc.so.6: version `GLIBC_2.14' not found The above failure is due to that fact that we are using the fixline1 tcl script to install commands under the example directory. The purpose of fixline1 is to ensure that the installed scripts begin with '#!/bin/sh'. However, the scripts under the example directory have already got the correct first line. That's why we don't need to modify anything and could just copy them. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/expect/expect')
-rw-r--r--meta/recipes-devtools/expect/expect/0001-expect-install-scripts-without-using-the-fixline1-tc.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/expect/expect/0001-expect-install-scripts-without-using-the-fixline1-tc.patch b/meta/recipes-devtools/expect/expect/0001-expect-install-scripts-without-using-the-fixline1-tc.patch
new file mode 100644
index 0000000000..274ad86353
--- /dev/null
+++ b/meta/recipes-devtools/expect/expect/0001-expect-install-scripts-without-using-the-fixline1-tc.patch
@@ -0,0 +1,34 @@
+Upstream-Status: Inappropriate [wrlinux specific]
+
+Subject: expect: install scripts without using the fixline1 tcl script
+
+On older machines like SLED11.2, we are encountering do_install failures
+complaining that 'GLIBC_2.14' is not found in /lib64/libc.so.6 but is required
+by libtcl8.6.so.0.
+
+This is because that we're executing the fixline1 tcl script which requires
+libtcl8.6.so.0 in sysroot. However, all commands in SCRIPTS already have got
+the correct first line, that is '#!/bin/sh'. We don't need to modify anything.
+That's why we could just copy them.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index c05c880..f1394ff 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -380,7 +380,7 @@ dist: dist-clean doc
+ cp $(DIST_ROOT)/$(PKG_DIR).tar.gz $(top_builddir)
+
+ $(SCRIPTS):
+- $(TCLSH) $(srcdir)/fixline1 $(SHORT_BINDIR) < $(srcdir)/example/$@ > $@
++ cp $(srcdir)/example/$@ $@
+
+ ## We cannot use TCL_LIBS below (after TCL_LIB_SPEC) because its
+ ## expansion references the contents of LIBS, which contains linker
+--
+1.7.10.4
+