aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-13 08:58:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-13 12:53:05 +0100
commit6467fb38f4770f45775bc795b75c7dbed9b039b7 (patch)
treea67104595a45325090940b74b7475a979ffc8ba7 /meta/recipes-devtools/elfutils
parentec22f5693b7c626484de9101370afc85c2710ea6 (diff)
downloadopenembedded-core-contrib-6467fb38f4770f45775bc795b75c7dbed9b039b7.tar.gz
elfutils: Fix debugedit failure in grub
We've seeing occasional debugedit failures in grub during do_package which in turn are coming from section alignment failures from libelf. The failures occur when gold is used to link grub instead of ld.bfd. "readelf -e uhci.module" shows: Section Headers: [Nr] Name Type Addr Off Size ES Flg Lk Inf Al [12] .note.GNU-stack PROGBITS 00000000 0010ce 000000 00 0 0 1 in a good build and: Section Headers: [Nr] Name Type Addr Off Size ES Flg Lk Inf Al [24] .note.GNU-stack PROGBITS 00000000 009180 000000 00 0 0 0 in a bad build. The problem is the "Al" (alignment) change from 1 to 0. If its 0, debugedit complains. As far as I can tell, the alignment of a zero length section is not an issue and the check in libelf should check the section size and only give alignment errors if there is some data to align. (From OE-Core rev: b34447fa5223b4e0be49594aaf0254defd69bbd1) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch24
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.158.bb12
2 files changed, 29 insertions, 7 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch b/meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch
new file mode 100644
index 0000000000..8796e9a394
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils-0.158/fixheadercheck.patch
@@ -0,0 +1,24 @@
+For some binaries we can get a invalid section alignment, for example if
+sh_align = 1 and sh_addralign is 0. In the case of a zero size section like
+".note.GNU-stack", this is irrelavent as far as I can tell and we shouldn't
+error in this case.
+
+RP 2014/6/11
+
+Upstream-Status: Pending
+
+Index: elfutils-0.158/libelf/elf32_updatenull.c
+===================================================================
+--- elfutils-0.158.orig/libelf/elf32_updatenull.c 2012-12-14 22:40:48.000000000 +0000
++++ elfutils-0.158/libelf/elf32_updatenull.c 2014-06-11 16:35:43.417386291 +0000
+@@ -327,8 +327,8 @@
+ we test for the alignment of the section being large
+ enough for the largest alignment required by a data
+ block. */
+- if (unlikely (! powerof2 (shdr->sh_addralign))
+- || unlikely (shdr->sh_addralign < sh_align))
++ if (shdr->sh_size && (unlikely (! powerof2 (shdr->sh_addralign))
++ || unlikely (shdr->sh_addralign < sh_align)))
+ {
+ __libelf_seterrno (ELF_E_INVALID_ALIGN);
+ return -1;
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.158.bb b/meta/recipes-devtools/elfutils/elfutils_0.158.bb
index e4253645bf..ef3dd0bb40 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.158.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.158.bb
@@ -25,13 +25,11 @@ SRC_URI += "\
file://core_filename.patch \
file://CVE-2014-0172.patch \
file://unwind_non_linux.patch \
-"
-
-SRC_URI += " \
- file://elf_additions.diff \
- file://mempcpy.patch \
- file://dso-link-change.patch \
- file://m4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch \
+ file://elf_additions.diff \
+ file://mempcpy.patch \
+ file://dso-link-change.patch \
+ file://m4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch \
+ file://fixheadercheck.patch \
"
# Only apply when building uclibc based target recipe