aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.158.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-13 08:58:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-13 12:52:46 +0100
commitb34447fa5223b4e0be49594aaf0254defd69bbd1 (patch)
treeeed80e1d1e14dff274d7afd58cd755d4b6a000e1 /meta/recipes-devtools/elfutils/elfutils_0.158.bb
parent92fc79690374aceaa3b821013cfe25604b1db18a (diff)
downloadopenembedded-core-contrib-b34447fa5223b4e0be49594aaf0254defd69bbd1.tar.gz
elfutils: Fix debugedit failure in grub
We've seeing occasional debugedit failures in grub during do_package which in turn are coming from section alignment failures from libelf. The failures occur when gold is used to link grub instead of ld.bfd. "readelf -e uhci.module" shows: Section Headers: [Nr] Name Type Addr Off Size ES Flg Lk Inf Al [12] .note.GNU-stack PROGBITS 00000000 0010ce 000000 00 0 0 1 in a good build and: Section Headers: [Nr] Name Type Addr Off Size ES Flg Lk Inf Al [24] .note.GNU-stack PROGBITS 00000000 009180 000000 00 0 0 0 in a bad build. The problem is the "Al" (alignment) change from 1 to 0. If its 0, debugedit complains. As far as I can tell, the alignment of a zero length section is not an issue and the check in libelf should check the section size and only give alignment errors if there is some data to align. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.158.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.158.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.158.bb b/meta/recipes-devtools/elfutils/elfutils_0.158.bb
index e4253645bf..ef3dd0bb40 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.158.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.158.bb
@@ -25,13 +25,11 @@ SRC_URI += "\
file://core_filename.patch \
file://CVE-2014-0172.patch \
file://unwind_non_linux.patch \
-"
-
-SRC_URI += " \
- file://elf_additions.diff \
- file://mempcpy.patch \
- file://dso-link-change.patch \
- file://m4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch \
+ file://elf_additions.diff \
+ file://mempcpy.patch \
+ file://dso-link-change.patch \
+ file://m4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch \
+ file://fixheadercheck.patch \
"
# Only apply when building uclibc based target recipe