aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2012-02-16 15:13:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-23 23:59:16 +0000
commit992604c533c9f3c2133cfa87c1121d43a508ec4a (patch)
treeb845b4459f0398a878ae8cd763b1e3410b4bb8a5 /meta/recipes-devtools/e2fsprogs
parentcd59c2fcefa6aeacf78a63c5c9a623a4d77c0941 (diff)
downloadopenembedded-core-contrib-992604c533c9f3c2133cfa87c1121d43a508ec4a.tar.gz
e2fsprogs: Cope with ${libdir} and ${base_libdir} being the same
${libdir} and ${base_libdir} may be the same. If they are don't try and move files onto themselves. Signed-off-by: Mike Crowe <mac@mcrowe.com>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb
index 2d36f697a0..6e3f7b8377 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb
@@ -1,6 +1,6 @@
require e2fsprogs.inc
-PR = "r3"
+PR = "r4"
SRC_URI += "file://fallocate.patch \
file://acinclude.m4 \
@@ -34,9 +34,11 @@ do_install () {
do_install_append () {
# e2initrd_helper and the pkgconfig files belong in libdir
- install -d ${D}${libdir}
- mv ${D}${base_libdir}/e2initrd_helper ${D}${libdir}
- mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
+ if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
+ install -d ${D}${libdir}
+ mv ${D}${base_libdir}/e2initrd_helper ${D}${libdir}
+ mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
+ fi
}
# blkid used to be part of e2fsprogs but is useful outside, add it