aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-17 19:01:05 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-19 11:29:04 +0000
commit1625faad281eeef3931573908c557362236dcd47 (patch)
tree53364de54dee54e70fb07536a2d4b8a1b2e0d1cf /meta/recipes-devtools/e2fsprogs
parent0b3842f5c3c1587d25e70bc8223e2b144b9043cb (diff)
downloadopenembedded-core-contrib-1625faad281eeef3931573908c557362236dcd47.tar.gz
e2fsprogs_1.42.bb: Fix build fallout for uclibc
e2fsprogs 1.42 onwards uses fallocate() which uclibc does not implement(yet). In most of places its use is controlled and it only used when configure detects fallocate being present but in this one case it missed to check for fallocate being available so here we add the check Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/fallocate.patch22
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb3
2 files changed, 24 insertions, 1 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/fallocate.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/fallocate.patch
new file mode 100644
index 0000000000..4d952a5df7
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/fallocate.patch
@@ -0,0 +1,22 @@
+We assume that fallocate is supported somehow
+but we need to check if we have fallocate()
+this problem shows up on uclibc systems since
+uclibc does not have fallocate() implemented
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: e2fsprogs-1.42/lib/ext2fs/unix_io.c
+===================================================================
+--- e2fsprogs-1.42.orig/lib/ext2fs/unix_io.c 2012-01-17 17:24:34.290780625 -0800
++++ e2fsprogs-1.42/lib/ext2fs/unix_io.c 2012-01-17 17:25:37.338783680 -0800
+@@ -895,7 +895,7 @@
+ goto unimplemented;
+ #endif
+ } else {
+-#ifdef FALLOC_FL_PUNCH_HOLE
++#if defined FALLOC_FL_PUNCH_HOLE && defined HAVE_FALLOCATE
+ /*
+ * If we are not on block device, try to use punch hole
+ * to reclaim free space.
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb
index 9ff85a2d51..f6759aa7d4 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.bb
@@ -1,8 +1,9 @@
require e2fsprogs.inc
-PR = "r0"
+PR = "r1"
SRC_URI += "file://quotefix.patch \
+ file://fallocate.patch \
file://acinclude.m4"
SRC_URI[md5sum] = "a3c4ffd7352310ab5e9412965d575610"