aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/docbook-utils
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-03-13 14:11:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 23:16:31 +0000
commit22510c756aa2b1b8d46f88ec08de47674a24d5c7 (patch)
treed61d8e07792d8dbb6405f04636e47842ecd0706e /meta/recipes-devtools/docbook-utils
parenta5cdf764a980624dbf350cb23cd360724c059584 (diff)
downloadopenembedded-core-contrib-22510c756aa2b1b8d46f88ec08de47674a24d5c7.tar.gz
docbook-utils: Add check to not sed files twice
This comes about from the code configure code getting run multiple times on the same WORKDIR and re-sed'ing already modified files. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/docbook-utils')
-rw-r--r--meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
index c2ccef3429..96459dc26f 100644
--- a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
+++ b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
@@ -7,7 +7,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "openjade-native sgmlspl-native docbook-dsssl-stylesheets-native docbook-sgml-dtd-3.1-native"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/docbook-utils-${PV}.tar.gz"
@@ -18,12 +18,15 @@ inherit autotools native
do_configure_prepend() {
# Fix hard-coded references to /etc/sgml
- sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
- sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
- sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
-
- # Point jw to the native sysroot catalog
- sed -i -e 's|^SGML_EXTRA_CATALOGS=""|SGML_EXTRA_CATALOGS=":${sysconfdir}/sgml/catalog"|g' bin/jw.in
+ if [ ! -e ${WORKDIR}/.sed_done ]; then
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
+
+ # Point jw to the native sysroot catalog
+ sed -i -e 's|^SGML_EXTRA_CATALOGS=""|SGML_EXTRA_CATALOGS=":${sysconfdir}/sgml/catalog"|g' bin/jw.in
+ touch ${WORKDIR}/.sed_done
+ fi
}
do_install() {