summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-08-18 16:02:46 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-19 22:15:38 +0100
commit342393587cdc364c12c0a0ba1694f3198cd49158 (patch)
tree7972e53845575e3f1ae73aa481b11e52fcabeef9 /meta/recipes-devtools/dnf
parenta09aa675bb8757a677c3f8289b459aa4a064aa34 (diff)
downloadopenembedded-core-contrib-342393587cdc364c12c0a0ba1694f3198cd49158.tar.gz
dnf: fix "Unable to detect release version" warning
The release version was actually working correctly; it only makes the warning work properly. (From OE-Core rev: e7986a5493ccd222b82c2388ea8c3bb7004b48dd) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf')
-rw-r--r--meta/recipes-devtools/dnf/dnf/0001-Check-conf.releasever-instead-of-releasever.patch31
-rw-r--r--meta/recipes-devtools/dnf/dnf_2.6.3.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf/0001-Check-conf.releasever-instead-of-releasever.patch b/meta/recipes-devtools/dnf/dnf/0001-Check-conf.releasever-instead-of-releasever.patch
new file mode 100644
index 0000000000..05f3141517
--- /dev/null
+++ b/meta/recipes-devtools/dnf/dnf/0001-Check-conf.releasever-instead-of-releasever.patch
@@ -0,0 +1,31 @@
+From 166833a88a928a574bf9143b9b65f544be482c77 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Fri, 18 Aug 2017 15:55:15 +0300
+Subject: [PATCH] Check conf.releasever instead of releasever
+
+The substitutions may actually set the conf.releasever correctly,
+and so the check should use that instead of the passed-in function
+parameter.
+
+Upstream-Status: Submitted [https://github.com/rpm-software-management/dnf/pull/901]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ dnf/cli/cli.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dnf/cli/cli.py b/dnf/cli/cli.py
+index 2d63420c..167943b8 100644
+--- a/dnf/cli/cli.py
++++ b/dnf/cli/cli.py
+@@ -914,7 +914,7 @@ class Cli(object):
+ conf.releasever = releasever
+ subst = conf.substitutions
+ subst.update_from_etc(conf.installroot)
+- if releasever is None:
++ if conf.releasever is None:
+ logger.warning(_("Unable to detect release version (use '--releasever' to specify "
+ "release version)"))
+
+--
+2.14.1
+
diff --git a/meta/recipes-devtools/dnf/dnf_2.6.3.bb b/meta/recipes-devtools/dnf/dnf_2.6.3.bb
index 51072901e4..3ed6a74570 100644
--- a/meta/recipes-devtools/dnf/dnf_2.6.3.bb
+++ b/meta/recipes-devtools/dnf/dnf_2.6.3.bb
@@ -10,6 +10,7 @@ SRC_URI = "git://github.com/rpm-software-management/dnf.git \
file://0001-Do-not-prepend-installroot-to-logdir.patch \
file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
file://0001-Corretly-install-tmpfiles.d-configuration.patch \
+ file://0001-Check-conf.releasever-instead-of-releasever.patch \
"
SRCREV = "be2585183ec4485ee4d5e121f242d8669296f065"