aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-05-13 21:06:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 11:25:03 +0100
commit6a2ead3f902c1941f6dec3a42232c31dd109cd0c (patch)
tree7e68e08c80df3b1e370f49df9627230e53f9239c /meta/recipes-devtools/distcc
parent9da097b0de6425464ebd3f0539b7495b11d139b5 (diff)
downloadopenembedded-core-contrib-6a2ead3f902c1941f6dec3a42232c31dd109cd0c.tar.gz
Revert "distcc: move ASNEEDED over-ride into the distcc recipe"
This reverts commit 3fbec7916c401b987184f4b25dda39cf355b2a60.
Diffstat (limited to 'meta/recipes-devtools/distcc')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.2.bb29
1 files changed, 9 insertions, 20 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.2.bb b/meta/recipes-devtools/distcc/distcc_3.2.bb
index ee077495d5..66046480b9 100644
--- a/meta/recipes-devtools/distcc/distcc_3.2.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.2.bb
@@ -7,6 +7,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "avahi binutils"
+PACKAGECONFIG ??= "popt"
+PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
+# use system popt by default
+PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
+
+RRECOMMENDS_${PN} = "avahi-daemon"
+
SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
file://separatebuilddir.patch \
file://0001-zeroconf-Include-fcntl.h.patch \
@@ -14,26 +21,12 @@ SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
file://distccmon-gnome.desktop \
file://distcc \
file://distcc.service"
-
SRCREV = "d8b18df3e9dcbe4f092bed565835d3975e99432c"
-
S = "${WORKDIR}/git"
inherit autotools pkgconfig update-rc.d useradd systemd
-PACKAGECONFIG ??= "popt"
-
-PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
-# use system popt by default
-PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
-
-EXTRA_OECONF += " \
- --disable-pump-mode \
- --disable-Werror \
- PYTHON='' \
-"
-
-ASNEEDED = ""
+EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system \
@@ -59,22 +52,18 @@ do_install() {
sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
${DESKTOPINSTALL}
}
-
DESKTOPINSTALL = ""
DESKTOPINSTALL_libc-glibc () {
install -d ${D}${datadir}/distcc/
install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
}
-
PACKAGES += "distcc-distmon-gnome"
FILES_${PN} = " ${sysconfdir} \
${bindir}/distcc \
- ${bindir}/lsdistcc \
+ ${bindir}/lsdistcc \
${bindir}/distccd \
${bindir}/distccmon-text \
${systemd_unitdir}/system/distcc.service"
FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
${datadir}/distcc"
-
-RRECOMMENDS_${PN} = "avahi-daemon"