summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/distcc_3.3.3.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-09-20 12:28:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-27 13:01:17 +0100
commitf69cb86f4c15497c6324a0e8063f86cc31cfe7aa (patch)
tree21c9c5f1d2f1d554e6e5db1345ec26ea57930dbc /meta/recipes-devtools/distcc/distcc_3.3.3.bb
parentabc51bfa8933dda99b6c82ac37692830315325b3 (diff)
downloadopenembedded-core-contrib-f69cb86f4c15497c6324a0e8063f86cc31cfe7aa.tar.gz
distcc: clean up the UI install logic
Remove the local copy of the desktop file, instead apply a patch from upstream to fix the file. This also fixes the install paths, so update the recipe. Remove glibc-specific installation as this was due to uclibc failures. Refresh and submit upstream the out-of-tree build fix. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/distcc/distcc_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.3.3.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.3.3.bb b/meta/recipes-devtools/distcc/distcc_3.3.3.bb
index 7942debec9..d8ad498f2b 100644
--- a/meta/recipes-devtools/distcc/distcc_3.3.3.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.3.3.bb
@@ -15,9 +15,9 @@ PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
RRECOMMENDS_${PN} = "avahi-daemon"
SRC_URI = "git://github.com/distcc/distcc.git \
+ file://fix-gnome.patch \
file://separatebuilddir.patch \
file://default \
- file://distccmon-gnome.desktop \
file://distcc \
file://distcc.service"
SRCREV = "4cde9bcfbda589abd842e3bbc652ce369085eaae"
@@ -51,13 +51,8 @@ do_install() {
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/distcc.service ${D}${systemd_unitdir}/system
sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
- ${DESKTOPINSTALL}
-}
-DESKTOPINSTALL = ""
-DESKTOPINSTALL_libc-glibc () {
- install -d ${D}${datadir}/distcc/
- install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
}
+
PACKAGES += "distcc-distmon-gnome"
FILES_${PN} = " ${sysconfdir} \
@@ -67,8 +62,10 @@ FILES_${PN} = " ${sysconfdir} \
${bindir}/distccmon-text \
${sbindir}/update-distcc-symlinks \
${systemd_unitdir}/system/distcc.service"
+
FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
- ${datadir}/distcc"
+ ${datadir}/applications \
+ ${datadir}/pixmaps"
#