aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/distcc_3.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-02-04 17:27:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-06 15:29:33 +0000
commitee58b618ec68c02b3e8759086e1dcc45c1fe3970 (patch)
tree16f8655830066ad6f8817066b9eba6ff672d319e /meta/recipes-devtools/distcc/distcc_3.1.bb
parent97ccd2b841c9dc598dbe39162f335bcde48a7c26 (diff)
downloadopenembedded-core-contrib-ee58b618ec68c02b3e8759086e1dcc45c1fe3970.tar.gz
distcc: rename systemd service to distcc
The sysv init script is called distcc, so rename the service to match so that in hybrid systemd/sysvinit images the service correctly masks the init script. This prevents such images from failing to start the distccd unit with error code 102, as the ports it wants to bind to are already taken. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/distcc/distcc_3.1.bb')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.1.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.1.bb b/meta/recipes-devtools/distcc/distcc_3.1.bb
index e3b6cda4b9..c69643c973 100644
--- a/meta/recipes-devtools/distcc/distcc_3.1.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.1.bb
@@ -22,7 +22,7 @@ SRC_URI = "http://distcc.googlecode.com/files/${BPN}-${PV}.tar.bz2 \
file://default \
file://distccmon-gnome.desktop \
file://distcc \
- file://distccd.service"
+ file://distcc.service"
SRC_URI[md5sum] = "a1a9d3853df7133669fffec2a9aab9f3"
SRC_URI[sha256sum] = "f55dbafd76bed3ce57e1bbcdab1329227808890d90f4c724fcd2d53f934ddd89"
@@ -41,7 +41,7 @@ USERADD_PARAM_${PN} = "--system \
INITSCRIPT_NAME = "distcc"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "distccd.service"
+SYSTEMD_SERVICE_${PN} = "distcc.service"
do_install_append() {
install -d ${D}${sysconfdir}/init.d/
@@ -49,8 +49,8 @@ do_install_append() {
install -m 0755 ${WORKDIR}/distcc ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/distcc
install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/distccd.service ${D}${systemd_unitdir}/system
- sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distccd.service
+ install -m 0644 ${WORKDIR}/distcc.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
${DESKTOPINSTALL}
}
DESKTOPINSTALL = ""
@@ -65,7 +65,7 @@ FILES_${PN} = " ${sysconfdir} \
${bindir}/lsdistcc \
${bindir}/distccd \
${bindir}/distccmon-text \
- ${systemd_unitdir}/system/distccd.service"
+ ${systemd_unitdir}/system/distcc.service"
FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
${datadir}/distcc"