aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/devel-config
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:38 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:54 -0700
commite6755e3351ccf1116c06b9608728630505908ce4 (patch)
treea3bb69e9aa55094baa3bfdd92e78c80d71cbec3f /meta/recipes-devtools/devel-config
parent971fbbd50ae147805fc7498b72a046be5bffc3c7 (diff)
downloadopenembedded-core-contrib-e6755e3351ccf1116c06b9608728630505908ce4.tar.gz
qemu-config: split out anjuta-remote-run
Given that support for Anjuta is unlikely to be needed by everyone and is by no means specific to qemu, split it out to a separate recipe. The following changes were made in the process: Also depend on dbus instead of dbus-x11 since dbus-launch is now back in he main dbus package Part of the fix for [YOCTO #1690]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/devel-config')
-rw-r--r--meta/recipes-devtools/devel-config/anjuta-remote-run.bb19
-rw-r--r--meta/recipes-devtools/devel-config/anjuta-remote-run/anjuta-remote-run7
2 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/devel-config/anjuta-remote-run.bb b/meta/recipes-devtools/devel-config/anjuta-remote-run.bb
new file mode 100644
index 0000000000..51fdf9ecac
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/anjuta-remote-run.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Provides on-device script for interaction with the Anjuta IDE"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://anjuta-remote-run"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 anjuta-remote-run ${D}${bindir}/
+}
+
+PACKAGES = "${PN}"
+RDEPENDS_${PN} = "dbus rsync"
+
+inherit allarch
+
diff --git a/meta/recipes-devtools/devel-config/anjuta-remote-run/anjuta-remote-run b/meta/recipes-devtools/devel-config/anjuta-remote-run/anjuta-remote-run
new file mode 100644
index 0000000000..620e3a705b
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/anjuta-remote-run/anjuta-remote-run
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+. /etc/profile
+export DISPLAY=:0
+dbus-launch $@
+
+