aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/devel-config
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:41 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commitc48f87a3fa9c61aaeedbcf5712a699c27d940a3b (patch)
treec6f819254006c0b651d3a9b3cd9017e42ee74430 /meta/recipes-devtools/devel-config
parent738005f4713c0da7bc04582a41efa956efdb9cc0 (diff)
downloadopenembedded-core-contrib-c48f87a3fa9c61aaeedbcf5712a699c27d940a3b.tar.gz
qemu-config: split out export of root via NFS to its own recipe
This need not be specific to qemu machines, allow it to be used elsewhere in isolation. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/devel-config')
-rw-r--r--meta/recipes-devtools/devel-config/nfs-export-root.bb17
-rw-r--r--meta/recipes-devtools/devel-config/nfs-export-root/exports1
2 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/devel-config/nfs-export-root.bb b/meta/recipes-devtools/devel-config/nfs-export-root.bb
new file mode 100644
index 0000000000..41259acfb3
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/nfs-export-root.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Enables NFS access from any host to the entire filesystem (for development purposes)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://exports"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 exports ${D}${sysconfdir}/
+}
+
+RDEPENDS_${PN} = "task-core-nfs-server"
+
+inherit allarch
diff --git a/meta/recipes-devtools/devel-config/nfs-export-root/exports b/meta/recipes-devtools/devel-config/nfs-export-root/exports
new file mode 100644
index 0000000000..b7257aa008
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/nfs-export-root/exports
@@ -0,0 +1 @@
+/ *(rw,no_root_squash,async)