summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-07-14 14:25:54 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-16 21:21:13 +0100
commited220fb35e828f9aa13af8db1ae1b2adf5f18e72 (patch)
treeb89313920161027071a670c9b784cbe315d230e5 /meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
parent5d113ccdd4ad45b628fa6f8f3142d250e82eb4a3 (diff)
downloadopenembedded-core-contrib-ed220fb35e828f9aa13af8db1ae1b2adf5f18e72.tar.gz
createrepo-c: upgrade 0.17.3 -> 0.17.4
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
new file mode 100644
index 0000000000..206c27c04f
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "C implementation of createrepo."
+HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
+ file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
+ "
+
+SRCREV = "cb74969736bdea86465e85feeceb895ff7a42610"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
+DEPENDS_append_class-native = " file-replacement-native"
+
+inherit cmake pkgconfig bash-completion distutils3-base
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
+ MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
+ create_wrapper ${D}/${bindir}/modifyrepo_c \
+ MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
+}
+
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
+ MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ create_wrapper ${D}/${bindir}/modifyrepo_c \
+ MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ rm -rf ${D}/etc
+}