summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.3.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-06-17 08:10:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-17 22:18:41 +0100
commit0ff4cfe6655853082771878bdcb4578fc08f7f12 (patch)
treeecb6494a30ef2204a79671748b61234f6a784caf /meta/recipes-devtools/createrepo-c/createrepo-c_0.17.3.bb
parent2d3c4ccaf429e64f3cbd41974c5bed1512c9d435 (diff)
downloadopenembedded-core-contrib-0ff4cfe6655853082771878bdcb4578fc08f7f12.tar.gz
createrepo-c: upgrade 0.17.2 -> 0.17.3
refresh 0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.17.3.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.3.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.3.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.3.bb
new file mode 100644
index 0000000000..481c4bff29
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.3.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "C implementation of createrepo."
+HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
+ file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
+ "
+
+SRCREV = "8196982f0974c268898a5550d61b374bd58103e2"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
+DEPENDS_append_class-native = " file-replacement-native"
+
+inherit cmake pkgconfig bash-completion distutils3-base
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
+ MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
+ create_wrapper ${D}/${bindir}/modifyrepo_c \
+ MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
+}
+
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
+ MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ create_wrapper ${D}/${bindir}/modifyrepo_c \
+ MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ rm -rf ${D}/etc
+}