aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake_3.11.4.bb
diff options
context:
space:
mode:
authorCody P Schafer <dev@codyps.com>2017-05-01 15:29:39 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-26 13:16:31 +0100
commitda60be3768e7183794d63548166d107dbd0a4973 (patch)
treebffd2bc7fba37df9387676062968be03a23ac97f /meta/recipes-devtools/cmake/cmake_3.11.4.bb
parent98c7ab9cf32765d604c35dc69bc7bd90e94fc8f3 (diff)
downloadopenembedded-core-contrib-da60be3768e7183794d63548166d107dbd0a4973.tar.gz
cmake: in SDK use OE env var to set default toolchain
Patch the location in cmake where the toolchain file is loaded to use the (new) OE_CMAKE_TOOLCHAIN_FILE variable to select a default toolchain if no toolchain has been specified. The cmake alias is removed. The alternatives: - shell alias fails when cmake is called indirectly (ex: a makefile managing several projects which calls cmake for some of them) because aliases are not inherited - wrapper script that unconditionally adds "-D..." breaks cmake's build tests and many other things as it causes cmake to believe it should be configuring things when it should not be. For example, `cmake -DCMAKE_TOOLCHAIN_FILE=... --build .` does not work (note that this also breaks people directly using `cmake --build .` with the current alias). Signed-off-by: Cody P Schafer <dev@codyps.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_3.11.4.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake_3.11.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_3.11.4.bb b/meta/recipes-devtools/cmake/cmake_3.11.4.bb
index 3f8fd7a997..eb055b9757 100644
--- a/meta/recipes-devtools/cmake/cmake_3.11.4.bb
+++ b/meta/recipes-devtools/cmake/cmake_3.11.4.bb
@@ -6,7 +6,9 @@ DEPENDS += "curl expat zlib libarchive xz ncurses bzip2"
SRC_URI_append_class-nativesdk = " \
file://OEToolchainConfig.cmake \
- file://environment.d-cmake.sh"
+ file://environment.d-cmake.sh \
+ file://0001-CMakeDetermineSystem-use-oe-environment-vars-to-load.patch \
+"
# Strip ${prefix} from ${docdir}, set result into docdir_stripped
python () {