aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake_2.8.11.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-05-20 19:20:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-24 14:07:01 +0100
commit13399264e987b698b120688dc5018adb3fa8522d (patch)
treed00d3506317b21d8bbfa586d920efd27b6845175 /meta/recipes-devtools/cmake/cmake_2.8.11.bb
parent5779021a7ad251a8359795a6a625e76a6befb3c7 (diff)
downloadopenembedded-core-contrib-13399264e987b698b120688dc5018adb3fa8522d.tar.gz
cmake: Update to 2.8.11
Rebased support-oe-qt4-tools-names as some of the changes where added in the upstream code. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_2.8.11.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake_2.8.11.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_2.8.11.bb b/meta/recipes-devtools/cmake/cmake_2.8.11.bb
new file mode 100644
index 0000000000..bc0715594c
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake_2.8.11.bb
@@ -0,0 +1,38 @@
+require cmake.inc
+
+inherit cmake
+
+DEPENDS += "curl expat zlib libarchive ncurses"
+
+SRC_URI += "file://dont-run-cross-binaries.patch"
+
+SRC_URI[md5sum] = "be6008f2299613d23fe82ab53ef7472e"
+SRC_URI[sha256sum] = "20d0d3661797fa82c19e7a75c7315c640e001cb3238331ca170bb0fae27feee5"
+
+# Strip ${prefix} from ${docdir}, set result into docdir_stripped
+python () {
+ prefix=d.getVar("prefix", True)
+ docdir=d.getVar("docdir", True)
+
+ if not docdir.startswith(prefix):
+ raise bb.build.FuncFailed('docdir must contain prefix as its prefix')
+
+ docdir_stripped = docdir[len(prefix):]
+ if len(docdir_stripped) > 0 and docdir_stripped[0] == '/':
+ docdir_stripped = docdir_stripped[1:]
+
+ d.setVar("docdir_stripped", docdir_stripped)
+}
+
+EXTRA_OECMAKE=" \
+ -DCMAKE_DOC_DIR=${docdir_stripped}/cmake-${CMAKE_MAJOR_VERSION} \
+ -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
+ -DKWSYS_CHAR_IS_SIGNED=1 \
+ -DBUILD_CursesDialog=0 \
+ ${@base_contains('DISTRO_FEATURES', 'largefile', '-DKWSYS_LFS_WORKS=1', '-DKWSYS_LFS_DISABLE=1', d)} \
+"
+
+FILES_${PN} += "${datadir}/cmake-${CMAKE_MAJOR_VERSION}"
+FILES_${PN}-doc += "${docdir}/cmake-${CMAKE_MAJOR_VERSION}"
+
+BBCLASSEXTEND = "nativesdk"