aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-11-16 19:59:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 14:24:05 +0000
commitb109a6e33fc7748de65d1ff76528b302e7f92dd8 (patch)
tree11c83c4e1fb7dd1586aacbbbf5fdf6cc015df074 /meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
parent1732197b53ba77a49792600c4c8385f4e44fe0bc (diff)
downloadopenembedded-core-contrib-b109a6e33fc7748de65d1ff76528b302e7f92dd8.tar.gz
cmake: Update to 2.8.10.1
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch')
-rw-r--r--meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch19
1 files changed, 10 insertions, 9 deletions
diff --git a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch b/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
index 4eb1794e4e..0c059f12ed 100644
--- a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
+++ b/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
@@ -7,16 +7,17 @@ Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-diff -ru cmake-2.8.2.orig/CMakeLists.txt cmake-2.8.2/CMakeLists.txt
---- cmake-2.8.2.orig/CMakeLists.txt 2010-07-28 00:48:42.000000000 +0200
-+++ cmake-2.8.2/CMakeLists.txt 2010-07-28 01:05:17.000000000 +0200
-@@ -518,7 +518,8 @@
+Index: cmake-2.8.10.1/CMakeLists.txt
+===================================================================
+--- cmake-2.8.10.1.orig/CMakeLists.txt
++++ cmake-2.8.10.1/CMakeLists.txt
+@@ -588,7 +588,8 @@ mark_as_advanced(CMAKE_STRICT)
# build the remaining subdirectories
- ADD_SUBDIRECTORY(Source)
--ADD_SUBDIRECTORY(Utilities)
+ add_subdirectory(Source)
+-add_subdirectory(Utilities)
+# Come on! Running the cross-binaries on host is not a good idea.
-+#ADD_SUBDIRECTORY(Utilities)
- ADD_SUBDIRECTORY(Tests)
++#add_subdirectory(Utilities)
+ add_subdirectory(Tests)
- # add a test
+ if(BUILD_TESTING)