aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-02-15 15:11:16 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commit798dba6fb3e16d3041b01faecfd32c787c142ee8 (patch)
treeb7156162976e4f72bd00d749c77a660f13e302f5 /meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
parent150d9d3215bf5d3a21c3f141d4ce837557c5f9f1 (diff)
downloadopenembedded-core-contrib-798dba6fb3e16d3041b01faecfd32c787c142ee8.tar.gz
cmake: Upgrade 3.10.1 -> 3.10.2
This is a minor stable update to CMake. This includes following changes: ,---- | c1e087a9d CMake 3.10.2 | d592bfc9f Autogen: Ignore not existing source files in cmMakefile | d49986b3b KWIML: Backport RISC-V update to CMake 3.10 | 9417a6d32 FindPostgreSQL: Add support for PG10 | 683e9023a Autogen: Fix for problematic nested list separator | 9b4d31dc7 cmGraphVizWriter: Updated to create and follow dependers for | interface targets `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.10.2.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.10.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
new file mode 100644
index 0000000000..e55e8b1cf6
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.10.2.bb
@@ -0,0 +1,38 @@
+require cmake.inc
+inherit native
+
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+
+SRC_URI += "\
+ file://cmlibarchive-disable-ext2fs.patch \
+"
+
+B = "${WORKDIR}/build"
+do_configure[cleandirs] = "${B}"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
+ -DBUILD_CursesDialog=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_configure () {
+ ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+do_compile[progress] = "percent"