aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-09 17:04:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-16 12:12:18 +0000
commit0b5cdddfc010f3641a13c284ad9ed61401055e3a (patch)
tree3cf74a5cc219a8ecc64a9acaec689b6f0e650fd0 /meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
parentc4dfb9291782fe6e2ae7eb74a1acc2ef5f10f8b6 (diff)
downloadopenembedded-core-contrib-0b5cdddfc010f3641a13c284ad9ed61401055e3a.tar.gz
cdrtools-native: update to 3.01 final
Inject a fake PV to avoid versions going backwards [RB] (From OE-Core rev: d7d96cffb920ba00d6ff5745b5aee0f3d81dc2bc) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb')
-rw-r--r--meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb b/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
new file mode 100644
index 0000000000..72ac741751
--- /dev/null
+++ b/meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
@@ -0,0 +1,24 @@
+# cdrtools-native OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+SUMMARY = "A set of tools for CD recording, including cdrecord"
+HOMEPAGE = "http://sourceforge.net/projects/cdrtools/"
+SECTION = "console/utils"
+LICENSE = "GPLv2 & CDDL-1.0 & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32f68170be424c2cd64804337726b312"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/cdrtools/cdrtools-${REALPV}.tar.bz2"
+
+SRC_URI[md5sum] = "7d45c5b7e1f78d85d1583b361aee6e8b"
+SRC_URI[sha256sum] = "ed282eb6276c4154ce6a0b5dee0bdb81940d0cbbfc7d03f769c4735ef5f5860f"
+
+inherit native
+
+PV = "3.01a31+really3.01"
+REALPV = "3.01"
+
+S = "${WORKDIR}/${BPN}-${REALPV}"
+
+do_install() {
+ make install GMAKE_NOWARN=true INS_BASE=${prefix} DESTDIR=${D}
+}