aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cdrtools/cdrtools-native_3.00.bb
diff options
context:
space:
mode:
authorAndrei Dinu <andrei.adrianx.dinu@intel.com>2013-05-17 10:37:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-21 00:15:28 +0100
commit951a8e422be93a3d06d0149f9b070eddcdb37afb (patch)
treecfe45bca418c512269de2d0107553f508ef2db58 /meta/recipes-devtools/cdrtools/cdrtools-native_3.00.bb
parenta32c05f691ef5620516b2f84452fb5129e16bb14 (diff)
downloadopenembedded-core-contrib-951a8e422be93a3d06d0149f9b070eddcdb37afb.tar.gz
cdrtools-native : upgrade to 3.00
Upgrade from 2.01 -> 3.00 - Updated md5 of the license file because new information was added by the owner. - Removed glibc-conflict-rename.patch because it is not required anymore. - Updated no_usr_src.patch because it didn't apply. Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cdrtools/cdrtools-native_3.00.bb')
-rw-r--r--meta/recipes-devtools/cdrtools/cdrtools-native_3.00.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cdrtools/cdrtools-native_3.00.bb b/meta/recipes-devtools/cdrtools/cdrtools-native_3.00.bb
new file mode 100644
index 0000000000..7e4c381f98
--- /dev/null
+++ b/meta/recipes-devtools/cdrtools/cdrtools-native_3.00.bb
@@ -0,0 +1,30 @@
+# cdrtools-native OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+SUMMARY = "A set of tools for CD recording, including cdrecord"
+DESCRIPTION = "A set of tools for CD recording, including cdrecord"
+HOMEPAGE = "http://cdrecord.berlios.de/private/cdrecord.html"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8d16123ffd39e649a5e4a6bc1de60e6d"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.berlios.de/pub/cdrecord/cdrtools-${PV}.tar.bz2 \
+ file://no_usr_src.patch"
+
+SRC_URI[md5sum] = "f9fbab08fbd458b0d2312976d8c5f558"
+SRC_URI[sha256sum] = "7f9cb64820055573b880f77b2f16662a512518336ba95ab49228a1617973423d"
+
+inherit native
+
+STAGE_TEMP = "${WORKDIR}/image-temp"
+
+FILESPATH = "${FILE_DIRNAME}/cdrtools-native/"
+
+do_install() {
+ install -d ${STAGE_TEMP}
+ make install INS_BASE=${STAGE_TEMP}
+
+ install -d ${D}${bindir}/
+ install ${STAGE_TEMP}/bin/* ${D}${bindir}/
+}