summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_4.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-28 21:04:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-31 11:53:21 +0000
commite373ecf276265a938a3acd42d9c25ce78d5f5330 (patch)
tree88cffc51b4b28450606aa192760776b33d0d0523 /meta/recipes-devtools/ccache/ccache_4.1.bb
parent72f86e4e986b70600a746eb219315b81b0367be3 (diff)
downloadopenembedded-core-contrib-e373ecf276265a938a3acd42d9c25ce78d5f5330.tar.gz
ccache: upgrade 3.7.11 -> 4.1
Convert recipe from autotools to cmake. zstd is a new hard dependency. License-Update: formatting Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_4.1.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.1.bb b/meta/recipes-devtools/ccache/ccache_4.1.bb
new file mode 100644
index 0000000000..5f7d93b485
--- /dev/null
+++ b/meta/recipes-devtools/ccache/ccache_4.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "a fast C/C++ compiler cache"
+DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
+by caching the result of previous compilations and detecting when the \
+same compilation is being done again. Supported languages are C, C\+\+, \
+Objective-C and Objective-C++."
+HOMEPAGE = "http://ccache.samba.org"
+SECTION = "devel"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=a66c581f855c1c408730fe5d171e3013"
+
+DEPENDS = "zstd"
+
+SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "cdeefb827b3eef3b42b5454858123881a4a90abbd46cc72cf8c20b3bd039deb7"
+
+UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
+
+inherit cmake
+
+PATCHTOOL = "patch"
+
+BBCLASSEXTEND = "native"
+