summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-12-02 12:38:04 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-03 12:19:43 +0000
commit9f5f4b31df01a29fd07ce27efc7534b4ea29a778 (patch)
tree74e9c76b743942f7063ddf17a9ebc3abca0debe9 /meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb
parente0564cbd6c824ba9ee1ed20a261261228fb594e3 (diff)
downloadopenembedded-core-contrib-9f5f4b31df01a29fd07ce27efc7534b4ea29a778.tar.gz
btrfs-tools: update to 4.19
Add a backported patch to fix big endian compilation. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb
new file mode 100644
index 0000000000..f5e0f77c8a
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Checksumming Copy on Write Filesystem utilities"
+DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
+implementing advanced features while focusing on fault tolerance, repair and \
+easy administration. \
+This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
+btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
+
+HOMEPAGE = "https://btrfs.wiki.kernel.org"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
+SECTION = "base"
+DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
+DEPENDS_append_class-target = " udev"
+RDEPENDS_${PN} = "libgcc"
+
+SRCREV = "d72d913291683188ddf5d758db02f1bc3b05d2f7"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
+ file://0001-Makefile-build-mktables-using-native-gcc.patch \
+ file://0001-Add-LDFLAGS-when-building-libbtrfsutil.so.patch \
+ file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
+ file://0001-btrfs-progs-kernel-lib-bitops-Fix-big-endian-compila.patch \
+ "
+
+inherit autotools-brokensep pkgconfig manpages distutils3-base
+
+CLEANBROKEN = "1"
+
+PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
+EXTRA_OECONF = " --disable-zstd"
+EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
+
+do_configure_prepend() {
+ # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
+ mkdir -p ${S}/config
+ cp -f $(automake --print-libdir)/install-sh ${S}/config/
+}
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
+}
+
+BBCLASSEXTEND = "native"